From 0d178956474c12a71baf14e357ed6476c97d055f Mon Sep 17 00:00:00 2001
From: renovate <renovate@archlinux.org>
Date: Sun, 4 Aug 2024 10:24:33 +0000
Subject: [PATCH] fix(deps): update dependency gunicorn to v22

---
 poetry.lock    | 13 +++++++------
 pyproject.toml |  2 +-
 2 files changed, 8 insertions(+), 7 deletions(-)

diff --git a/poetry.lock b/poetry.lock
index 94eb232a2..13e65a452 100644
--- a/poetry.lock
+++ b/poetry.lock
@@ -691,22 +691,23 @@ test = ["objgraph", "psutil"]
 
 [[package]]
 name = "gunicorn"
-version = "21.2.0"
+version = "22.0.0"
 description = "WSGI HTTP Server for UNIX"
 optional = false
-python-versions = ">=3.5"
+python-versions = ">=3.7"
 files = [
-    {file = "gunicorn-21.2.0-py3-none-any.whl", hash = "sha256:3213aa5e8c24949e792bcacfc176fef362e7aac80b76c56f6b5122bf350722f0"},
-    {file = "gunicorn-21.2.0.tar.gz", hash = "sha256:88ec8bff1d634f98e61b9f65bc4bf3cd918a90806c6f5c48bc5603849ec81033"},
+    {file = "gunicorn-22.0.0-py3-none-any.whl", hash = "sha256:350679f91b24062c86e386e198a15438d53a7a8207235a78ba1b53df4c4378d9"},
+    {file = "gunicorn-22.0.0.tar.gz", hash = "sha256:4a0b436239ff76fb33f11c07a16482c521a7e09c1ce3cc293c2330afe01bec63"},
 ]
 
 [package.dependencies]
 packaging = "*"
 
 [package.extras]
-eventlet = ["eventlet (>=0.24.1)"]
+eventlet = ["eventlet (>=0.24.1,!=0.36.0)"]
 gevent = ["gevent (>=1.4.0)"]
 setproctitle = ["setproctitle"]
+testing = ["coverage", "eventlet", "gevent", "pytest", "pytest-cov"]
 tornado = ["tornado (>=0.2)"]
 
 [[package]]
@@ -2080,4 +2081,4 @@ testing = ["big-O", "jaraco.functools", "jaraco.itertools", "more-itertools", "p
 [metadata]
 lock-version = "2.0"
 python-versions = ">=3.9,<3.13"
-content-hash = "e7bd6a15ffcb1998f5fbc6e7b570e023f85c61985568519a11b5bf7283239560"
+content-hash = "ce2a44edc7cccf4e674e6663ebdc56f3e8c0881f07f3e9c275053ce67da2cae1"
diff --git a/pyproject.toml b/pyproject.toml
index 440391dba..214d1171c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -87,7 +87,7 @@ SQLAlchemy = "^1.4.52"
 
 # ASGI
 uvicorn = "^0.30.0"
-gunicorn = "^21.2.0"
+gunicorn = "^22.0.0"
 Hypercorn = "^0.17.0"
 prometheus-fastapi-instrumentator = "^7.0.0"
 pytest-xdist = "^3.5.0"
-- 
GitLab