Verified Commit d4210c53 authored by Kevin Morris's avatar Kevin Morris
Browse files

fix: update poetry dependencies



There were some test failures caused by problematic
dependency versioning, most likely to to the seriously
braindead pyproject.toml config for deps that previously
existed.

This commit defines python version >=3.9<3.10 for our working
Python version and provides updated deps (to latest).

I believe the bug was originally caused by the fact that
we had no python dependency defined, allowing poetry to
resolve dependencies incorrectly for what we intended.
Signed-off-by: Kevin Morris's avatarKevin Morris <kevr@0cost.org>
parent d5520c9e
This diff is collapsed.
......@@ -43,50 +43,54 @@ build-backend = "poetry.masonry.api"
"Request Mailing List" = "https://lists.archlinux.org/listinfo/aur-requests"
[tool.poetry.dependencies]
python = ">=3.9,<3.10"
# poetry-dynamic-versioning is used to produce tool.poetry.version
# based on git tags.
poetry-dynamic-versioning = { version = "0.13.1", python = "^3.9" }
poetry-dynamic-versioning = "^0.13.1"
# General
authlib = { version = "0.15.2", python = "^3.9" }
aiofiles = { version = "0.7.0", python = "^3.9" }
asgiref = { version = "3.4.1", python = "^3.9" }
bcrypt = { version = "3.2.0", python = "^3.9" }
bleach = { version = "3.3.1", python = "^3.9" }
email-validator = { version = "1.1.3", python = "^3.9" }
fakeredis = { version = "1.6.0", python = "^3.9" }
fastapi = { version = "0.66.0", python = "^3.9" }
feedgen = { version = "0.9.0", python = "^3.9" }
httpx = { version = "0.18.2", python = "^3.9" }
hypercorn = { version = "0.11.2", python = "^3.9" }
itsdangerous = { version = "2.0.1", python = "^3.9" }
jinja2 = { version = "3.0.1", python = "^3.9" }
lxml = { version = "4.6.3", python = "^3.9" }
markdown = { version = "3.3.4", python = "^3.9" }
orjson = { version = "3.6.3", python = "^3.9" }
protobuf = { version = "3.17.3", python = "^3.9" }
pygit2 = { version = "1.6.1", python = "^3.9" }
python-multipart = { version = "0.0.5", python = "^3.9" }
redis = { version = "3.5.3", python = "^3.9" }
requests = { version = "2.26.0", python = "^3.9" }
werkzeug = { version = "2.0.1", python = "^3.9" }
paginate = { version = "0.5.6", python = "^3.9" }
aiofiles = "^0.7.0"
asgiref = "^3.4.1"
bcrypt = "^3.2.0"
bleach = "^4.1.0"
email-validator = "^1.1.3"
fakeredis = "^1.6.1"
fastapi = "^0.70.0"
feedgen = "^0.9.0"
httpx = "^0.20.0"
itsdangerous = "^2.0.1"
lxml = "^4.6.3"
orjson = "^3.6.4"
protobuf = "^3.19.0"
pygit2 = "^1.7.0"
python-multipart = "^0.0.5"
redis = "^3.5.3"
requests = "^2.26.0"
paginate = "^0.5.6"
# SQL
alembic = { version = "1.6.5", python = "^3.9" }
sqlalchemy = { version = "1.3.23", python = "^3.9" }
mysqlclient = { version = "2.0.3", python = "^3.9" }
alembic = "^1.7.4"
mysqlclient = "^2.0.3"
Authlib = "^0.15.5"
Jinja2 = "^3.0.2"
Markdown = "^3.3.4"
Werkzeug = "^2.0.2"
SQLAlchemy = "^1.4.26"
# ASGI
uvicorn = "^0.15.0"
gunicorn = "^20.1.0"
Hypercorn = "^0.11.2"
[tool.poetry.dev-dependencies]
flake8 = { version = "3.9.2", python = "^3.9" }
isort = { version = "5.9.3", python = "^3.9" }
coverage = { version = "5.5", python = "^3.9" }
pytest = { version = "6.2.4", python = "^3.9" }
pytest-asyncio = { version = "0.15.1", python = "^3.9" }
pytest-cov = { version = "2.12.1", python = "^3.9" }
pytest-tap = { version = "3.2", python = "^3.9" }
uvicorn = { version = "0.15.0", python = "^3.9" }
gunicorn = { version = "20.1.0", python = "^3.9" }
flake8 = "^4.0.1"
isort = "^5.9.3"
coverage = "^6.0.2"
pytest = "^6.2.5"
pytest-asyncio = "^0.16.0"
pytest-cov = "^3.0.0"
pytest-tap = "^3.2"
[tool.poetry.scripts]
aurweb-git-auth = "aurweb.git.auth:main"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment