Commit ce4f2865 authored by Kristian Klausen's avatar Kristian Klausen 🎉
Browse files

ci: Install ansible so ansible-lint can resolve the modules

ansible-lint no longer depends on ansible[1][2] which causes it to fail
with: syntax-check: couldn't resolve module/action 'pacman', as the
modules is part of ansible and not ansible-base.

[1] https://bugs.archlinux.org/task/69920
[2] https://github.com/archlinux/svntogit-community/commit/a3ccb42b8dc104a4616a64fac4a1f6dd44ffedca
parent 13aee0c1
image: "archlinux:latest" image: "archlinux:latest"
before_script: before_script:
- pacman -Syu --needed --noconfirm ansible-lint yamllint terraform - pacman -Syu --needed --noconfirm ansible-lint ansible yamllint terraform
ansible-lint: ansible-lint:
script: script:
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment