diff --git a/PKGBUILD b/PKGBUILD
index 90de852e33acfd4b895da4d2d76b3c59990cd193..3a6c150861f23a20adf0548dde0074358fd138c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=firefox
 pkgver=43.0
-pkgrel=1
+pkgrel=2
 pkgdesc="Standalone web browser from mozilla.org"
 arch=('i686' 'x86_64')
 license=('MPL' 'GPL' 'LGPL')
@@ -12,9 +12,11 @@ depends=('gtk3' 'gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-typ
          'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
          'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font')
 makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
-             'xorg-server-xvfb' 'libpulse' 'inetutils')
+             'xorg-server-xvfb' 'libpulse' 'inetutils' 'gst-plugins-base-libs')
 optdepends=('networkmanager: Location detection via available WiFi networks'
             'ffmpeg: H264/AAC decoding'
+            'gst-plugins-good: MP3 playback'
+            'gst-plugins-ugly: MP3 playback'
             'upower: Battery API')
 install=firefox.install
 options=('!emptydirs' '!makeflags')
@@ -25,7 +27,7 @@ source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/
         vendor.js
         firefox-fixed-loading-icon.png)
 sha256sums=('a5b16741dcce9344ca71e39e0efb0e7e1336ca5160cb9b6b12f8985f402d8fea'
-            'b8ecaae997c6a9e3b99903be7aa7c02d46cc0c4b7d6334e796fa32dc8eccc692'
+            '0a6968180eba6d66b549cebb4106540280600614e91a72a95955e739d4b75fb9'
             'c202e5e18da1eeddd2e1d81cb3436813f11e44585ca7357c4c5f1bddd4bec826'
             'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
             '4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
diff --git a/mozconfig b/mozconfig
index 4024c129f2534d72908ef832838dfcb1ac718108..c8d5dcf9a79e751acfb8f6c63a09ce3797b1816d 100644
--- a/mozconfig
+++ b/mozconfig
@@ -2,6 +2,8 @@
 
 ac_add_options --prefix=/usr
 ac_add_options --libdir=/usr/lib
+ac_add_options --enable-release
+ac_add_options --enable-gold
 ac_add_options --enable-pie
 
 ac_add_options --enable-official-branding
@@ -27,7 +29,7 @@ ac_add_options --enable-system-pixman
 # Features
 ac_add_options --enable-startup-notification
 ac_add_options --enable-pulseaudio
-ac_add_options --disable-gstreamer
+ac_add_options --enable-gstreamer=1.0
 
 ac_add_options --disable-crashreporter
 ac_add_options --disable-updater