diff --git a/PKGBUILD b/PKGBUILD
index a7d9daaa6162742523f5c6ac5068727a60cb6be0..090c490689e6e066b728d56e8513138d6caf89d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -72,16 +72,9 @@ build() {
   export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/firefox"
   export PYTHON="/usr/bin/python2"
 
-  # Set up PGO
-  export DISPLAY=:99
-  Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
-
-  if ! make -f client.mk build MOZ_PGO=1; then
-    kill $!
-    return 1
-  fi
-
-  kill $! || true
+  # Do PGO
+  xvfb-run -a -s "-extension GLX -screen 0 1280x1024x24" \
+    make -f client.mk build MOZ_PGO=1
 }
 
 package() {