Skip to content
Snippets Groups Projects
Commit b48e9052 authored by Ionuț Mircea Bîru's avatar Ionuț Mircea Bîru
Browse files

update to 7.0.1, drop the point release from /usr/lib/firefox-

parent dfa76b69
No related branches found
Tags 7.0.1-1
No related merge requests found
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox
pkgver=7.0
pkgver=7.0.1
pkgrel=1
pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64')
......@@ -11,23 +11,25 @@ makedepends=('unzip' 'zip' 'pkg-config' 'diffutils' 'python2' 'wireless_tools' '
url="http://www.mozilla.org/projects/firefox"
install=firefox.install
source=(ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases//${pkgver}/source/firefox-${pkgver}.source.tar.bz2
mozconfig firefox.desktop mozilla-firefox-1.0-lang.patch)
md5sums=('673a015a23e3fefa18d80db68c8b9fc1'
mozconfig firefox.desktop mozilla-firefox-1.0-lang.patch firefox-version.patch)
md5sums=('5b212db48630ba93bb30ec63cca17f4d'
'd88607e98806db2a7eb222b0c8635af0'
'bdeb0380c7fae30dd0ead6d2d3bc5873'
'bd5db57c23c72a02a489592644f18995')
'bd5db57c23c72a02a489592644f18995'
'ff4654144499faf630271cddc2261b7c')
build() {
cd "$srcdir/mozilla-release"
cp "$srcdir/mozconfig" .mozconfig
patch -Np1 -i "$srcdir/mozilla-firefox-1.0-lang.patch"
patch -Np1 -i "$srcdir/firefox-version.patch"
# Fix PRE_RELEASE_SUFFIX
sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
browser/base/Makefile.in
export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-$pkgver -Wl,-O1,--sort-common,--hash-style=gnu,--as-needed"
export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-7.0 -Wl,-O1,--sort-common,--hash-style=gnu,--as-needed"
export PYTHON="/usr/bin/python2"
# PGO
......@@ -53,10 +55,14 @@ package() {
install -Dm644 "$srcdir/firefox.desktop" \
"$pkgdir/usr/share/applications/firefox.desktop"
rm -rf "$pkgdir"/usr/lib/firefox-$pkgver/{dictionaries,hyphenation}
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/firefox-$pkgver/dictionaries"
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/firefox-$pkgver/hyphenation"
rm -rf "$pkgdir"/usr/lib/firefox-7.0/{dictionaries,hyphenation}
ln -sf /usr/share/hunspell "$pkgdir/usr/lib/firefox-7.0/dictionaries"
ln -sf /usr/share/hyphen "$pkgdir/usr/lib/firefox-7.0/hyphenation"
# We don't want the development stuff
rm -r "$pkgdir"/usr/{include,lib/firefox-devel-$pkgver,share/idl}
rm -r "$pkgdir"/usr/{include,lib/firefox-devel-7.0,share/idl}
#workaround for now
#https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -sf /usr/lib/firefox-7.0/firefox-bin "$pkgdir/usr/lib/firefox-7.0/firefox"
}
diff -Nur mozilla-release.orig/browser/installer/Makefile.in mozilla-release/browser/installer/Makefile.in
--- mozilla-release.orig/browser/installer/Makefile.in 2011-09-30 08:45:28.858668017 +0000
+++ mozilla-release/browser/installer/Makefile.in 2011-09-30 08:51:01.548314685 +0000
@@ -43,6 +43,8 @@
include $(DEPTH)/config/autoconf.mk
+MOZ_APP_VERSION="7.0"
+
include $(topsrcdir)/config/rules.mk
MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment