From ddcebad4fd5eba80d5b99a22bcd11611bfd237b2 Mon Sep 17 00:00:00 2001
From: Jan Alexander Steffens <heftig@archlinux.org>
Date: Fri, 17 Mar 2017 23:56:40 +0000
Subject: [PATCH] 52.0.1-1

---
 PKGBUILD | 30 ++++++++++++++----------------
 1 file changed, 14 insertions(+), 16 deletions(-)

diff --git a/PKGBUILD b/PKGBUILD
index 0271a33..e6d8434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
 # Contributor: Jakub Schmidtke <sjakub@gmail.com>
 
 pkgname=firefox
-pkgver=52.0
-pkgrel=2
+pkgver=52.0.1
+pkgrel=1
 pkgdesc="Standalone web browser from mozilla.org"
 arch=(i686 x86_64)
 license=(MPL GPL LGPL)
@@ -12,22 +12,21 @@ url="https://www.mozilla.org/firefox/"
 depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
          libvpx libevent nss hunspell sqlite ttf-font icu)
 makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb
-             autoconf2.13 cargo)
+             autoconf2.13 cargo mercurial)
 optdepends=('networkmanager: Location detection via available WiFi networks'
             'libnotify: Notification integration'
-            'upower: Battery API'
             'speech-dispatcher: Text-to-Speech')
-options=(!emptydirs !makeflags)
-source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz
+options=(!emptydirs !makeflags !strip)
+_repo=https://hg.mozilla.org/releases/mozilla-release
+source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
         firefox.desktop firefox-symbolic.svg
         firefox-install-dir.patch rust-i686.patch fix-wifi-scanner.diff)
-sha256sums=('494ec86875ea60043658e402b664ccd5af4709acc3a478de8729f7cbac9ea3c1'
+sha256sums=('SKIP'
             'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
             'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
             'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
             'f61ea706ce6905f568b9bdafd1b044b58f20737426f0aa5019ddb9b64031a269'
             '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
-validpgpkeys=('2B90598A745E992F315E22C58AB132963A06537A')
 
 # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
 # Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -41,12 +40,11 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
 # more information.
 _mozilla_api_key=16674381-f021-49de-8622-3021c5942aff
 
-
 prepare() {
   mkdir path
   ln -s /usr/bin/python2 path/python
 
-  cd $pkgname-$pkgver
+  cd mozilla-release
   patch -Np1 -i ../firefox-install-dir.patch
 
   # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
@@ -70,6 +68,9 @@ ac_add_options --enable-rust
 # Branding
 ac_add_options --enable-official-branding
 ac_add_options --enable-update-channel=release
+export MOZILLA_OFFICIAL=1
+export MOZ_TELEMETRY_REPORTING=1
+export MOZ_SOURCE_REPO=${_repo@Q}
 export MOZ_ADDON_SIGNING=1
 export MOZ_REQUIRE_SIGNING=1
 
@@ -93,8 +94,8 @@ ac_add_options --enable-system-pixman
 
 # Features
 ac_add_options --enable-startup-notification
+ac_add_options --enable-crashreporter
 ac_add_options --enable-alsa
-ac_add_options --disable-crashreporter
 ac_add_options --disable-updater
 
 STRIP_FLAGS="--strip-debug"
@@ -102,7 +103,7 @@ END
 }
 
 build() {
-  cd $pkgname-$pkgver
+  cd mozilla-release
 
   # _FORTIFY_SOURCE causes configure failures
   CPPFLAGS+=" -O2"
@@ -110,9 +111,6 @@ build() {
   # Hardening
   LDFLAGS+=" -Wl,-z,now"
 
-  # GCC 6
-  CXXFLAGS+=" -fno-delete-null-pointer-checks -fno-schedule-insns2"
-
   export PATH="$srcdir/path:$PATH"
 
   # Do PGO
@@ -122,7 +120,7 @@ build() {
 }
 
 package() {
-  cd $pkgname-$pkgver
+  cd mozilla-release
   make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
 
   _vendorjs="$pkgdir/usr/lib/firefox/browser/defaults/preferences/vendor.js"
-- 
GitLab