From f429e4b1065977074cba661d42491ad2c1c000f2 Mon Sep 17 00:00:00 2001
From: Jan Alexander Steffens <heftig@archlinux.org>
Date: Tue, 17 Sep 2013 06:12:45 +0000
Subject: [PATCH] 24.0

---
 PKGBUILD  | 24 +++++++++++++++++++-----
 mozconfig |  2 +-
 2 files changed, 20 insertions(+), 6 deletions(-)

diff --git a/PKGBUILD b/PKGBUILD
index 7f3c475..318c29a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
 # Contributor: Jakub Schmidtke <sjakub@gmail.com>
 
 pkgname=firefox
-pkgver=23.0.1
+pkgver=24.0
 pkgrel=1
 pkgdesc="Standalone web browser from mozilla.org"
 arch=('i686' 'x86_64')
@@ -12,22 +12,32 @@ depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
          'dbus-glib' 'alsa-lib' 'libvpx' 'libevent' 'nss' 'hunspell' 'sqlite'
           'libnotify' 'desktop-file-utils' 'hicolor-icon-theme')
 makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake'
-             'xorg-server-xvfb' 'libpulse')
+             'xorg-server-xvfb' 'libpulse' 'gstreamer0.10-base')
 optdepends=('networkmanager: Location detection via available WiFi networks'
+            'gstreamer0.10-base-plugins: vorbis decoding, ogg demuxing'
+            'gstreamer0.10-bad-plugins: aac, vp8 and opus decoding'
+            'gstreamer0.10-good-plugins: webm and mp4 demuxing'
+            'gstreamer0.10-ugly-plugins: h.264 decoding'
             'libpulse: PulseAudio audio driver')
 install=firefox.install
 options=('!emptydirs' '!makeflags')
 source=(https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.bz2
         mozconfig firefox.desktop firefox-install-dir.patch vendor.js shared-libs.patch
         firefox-20.0.1-fixed-loading-icon.png)
-sha256sums=('bb2c2e99a03859ebd8c02b8bc4c57b39ccc97c55872c2737c433212c0ebe01cf'
-            '1d750088958ae2a2faf43f9bb3909c3e396f01c6504ba39f09b8ed7fc1b29492'
+sha256sums=('86a6efa501e1b106b597a8506757f3a2db9d3a5cfcc61ea29a9ad0c834bea83b'
+            'b94ec94cb5e4bbeb45637425bb4efa3051a16ed12cea2ee3b0a5b9cb48ef4115'
             'd2a7610393ba259c35e3227b92e02ec91095a95189f56ac93ccdf6732772719c'
             'ded67e8204bd5e1c0c5771c0d2c84ff80c998e1543711e7cd804cfe29e8dd1b0'
             '4b50e9aec03432e21b44d18c4c97b2630bace606b033f7d556c9d3e3eb0f4fa4'
             'e2b4a00d14f4ba69c62b3f9ef9908263fbab179ba8004197cbc67edbd916fdf1'
             '68e3a5b47c6d175cc95b98b069a15205f027cab83af9e075818d38610feb6213')
 
+# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
+# Note: These are for Arch Linux use ONLY. For your own distribution, please
+# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
+# more information.
+_google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
+
 prepare() {
   cd mozilla-release
 
@@ -39,6 +49,8 @@ prepare() {
   sed -i '/^PRE_RELEASE_SUFFIX := ""/s/ ""//' \
     browser/base/Makefile.in
 
+  echo -n "$_google_api_key" >google-api-key
+
   mkdir "$srcdir/path"
 
   # WebRTC build tries to execute "python" and expects Python 2
@@ -92,7 +104,9 @@ package() {
   install -Dm644 browser/branding/official/mozicon128.png \
     "$pkgdir/usr/share/icons/hicolor/128x128/apps/firefox.png"
   install -Dm644 browser/branding/official/content/about-logo.png \
-    "$pkgdir/usr/share/icons/hicolor/210x210/apps/firefox.png"
+    "$pkgdir/usr/share/icons/hicolor/192x192/apps/firefox.png"
+  install -Dm644 browser/branding/official/content/about-logo@2x.png \
+    "$pkgdir/usr/share/icons/hicolor/384x384/apps/firefox.png"
 
   install -Dm644 ../firefox.desktop \
     "$pkgdir/usr/share/applications/firefox.desktop"
diff --git a/mozconfig b/mozconfig
index ec5ad7a..fb5ee33 100644
--- a/mozconfig
+++ b/mozconfig
@@ -4,6 +4,7 @@ ac_add_options --prefix=/usr
 ac_add_options --libdir=/usr/lib
 
 ac_add_options --enable-official-branding
+ac_add_options --with-google-api-keyfile=google-api-key
 
 # System libraries
 ac_add_options --with-system-nspr
@@ -22,7 +23,6 @@ ac_add_options --enable-system-pixman
 
 # Features
 ac_add_options --enable-startup-notification
-#ac_add_options --enable-gstreamer
 ac_add_options --enable-pulseaudio
 
 ac_add_options --disable-crashreporter
-- 
GitLab