diff --git a/PKGBUILD b/PKGBUILD
index 79cc6245ba5fccf5401ac013844219cafc54ac25..a9f9b8bb08e07d71e11e010cfa5b72145c7df15c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
 # Contributor: uastasi <uastasi@archlinux.us>
 
 pkgname=gnote
-pkgver=3.32.1
+pkgver=3.34.0
 pkgrel=1
 pkgdesc="A note taking application"
 url="https://wiki.gnome.org/Apps/Gnote"
 arch=(x86_64)
 license=(GPL3)
-depends=(gtkmm3 gtkspell3 libxslt dconf libsecret)
-makedepends=(intltool boost yelp-tools autoconf-archive git)
-_commit=8db9d17782c85739e41780b7f966f2ba3a457606  # tags/3.32.1^0
+depends=(gtkmm3 gspell libxslt dconf libsecret)
+makedepends=(intltool yelp-tools autoconf-archive git)
+_commit=93d29902f9d14f2a0c3f7e70103f9cbfca16a173  # tags/3.34.0^0
 source=("git+https://gitlab.gnome.org/GNOME/gnote.git#commit=$_commit")
 sha256sums=('SKIP')
 
@@ -29,7 +29,7 @@ build() {
   ./configure --prefix=/usr \
     --sysconfdir=/etc \
     --localstatedir=/var \
-    --libexecdir=/usr/lib/$pkgname \
+    --libexecdir=/usr/lib \
     --disable-schemas-compile \
     --disable-static
   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool