diff --git a/PKGBUILD b/PKGBUILD
index 31a938b67780e50e1b3b31e86b4aa159573d406e..1c06936400f7679bcae79f84d9bed22e6f06dc75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,23 @@
 # Contributor: uastasi <uastasi@archlinux.us>
 
 pkgname=gnote
-pkgver=3.20.0
+pkgver=3.20.1
 pkgrel=1
-pkgdesc='A note taking application'
-arch=('i686' 'x86_64')
-url='https://wiki.gnome.org/action/show/Apps/Gnote'
-license=('GPL3')
-depends=('gtkmm3' 'libxslt' 'hicolor-icon-theme' 'desktop-file-utils' 'dconf' 'libsecret')
-makedepends=('intltool' 'itstool' 'boost')
-install=gnote.install
+pkgdesc="A note taking application"
+url="https://wiki.gnome.org/Apps/Gnote"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(gtkmm3 gtkspell3 libxslt dconf libsecret)
+makedepends=(intltool itstool boost)
 source=(https://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz)
-sha256sums=('4c363595e6f2d1a9a640f02c83e4b8680ea6d3101315e59d39c4db2d585f81a9')
+sha256sums=('75acffdc2c0cc8cd226dc4471e6624d523bbd86c415ef4e05be70cbbfd4014e7')
 
 build() {
   cd $pkgname-$pkgver
   ./configure --prefix=/usr \
     --sysconfdir=/etc \
     --localstatedir=/var \
-    --libexecdir=/usr/lib/gnote \
-    --disable-scrollkeeper \
+    --libexecdir=/usr/lib/$pkgname \
     --disable-schemas-compile \
     --disable-static
   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
diff --git a/gnote.install b/gnote.install
deleted file mode 100644
index 0f8eb101289825777c18449c9695776fd84ecbea..0000000000000000000000000000000000000000
--- a/gnote.install
+++ /dev/null
@@ -1,21 +0,0 @@
-pkgname=gnote
-
-post_install() {
-    glib-compile-schemas usr/share/glib-2.0/schemas
-    gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-    update-desktop-database -q
-}
-
-pre_upgrade() {
-    if [ -f usr/share/gconf/schemas/${pkgname}.schemas ]; then
-        usr/sbin/gconfpkg --uninstall ${pkgname}
-    fi
-}
-
-post_upgrade() {
-    post_install
-}
-
-post_remove() {
-    post_install
-}