From d5d950914426098cacf7ec708a4bf0d4048e40a0 Mon Sep 17 00:00:00 2001
From: Evangelos Foutras <foutrelis@archlinux.org>
Date: Wed, 15 Nov 2017 14:29:11 +0000
Subject: [PATCH] Remove i686 from arch=()

FTR, commands used to change arch=() and then verify the changes:

$ sed -Ei "/^arch=/{s/ *?['\"]?i686['\"]? *?//;s/ *$//}" */*/PKGBUILD*

$ grep -r i686 * | grep arch= | grep -v repos

$ svn diff | grep -A 1 ^-[^-] | grep -v -- -- | cut -c2- |
  while IFS=$'\n' read -r l1; IFS=$'\n' read -r l2; do
    echo "$l1 -> $l2"
  done | sort -u
---
 PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD
index 9f17854..8fbf0bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=3
 pkgdesc="Low-level binding to POSIX uname(3)"
 url="https://hackage.haskell.org/package/bindings-uname"
 license=("custom:PublicDomain")
-arch=('i686' 'x86_64')
+arch=('x86_64')
 depends=('ghc-libs')
 makedepends=('ghc')
 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-- 
GitLab