From 79e97d9cd010ae2cb2630436df4990c773bb04e4 Mon Sep 17 00:00:00 2001
From: Felix Yan <felixonmars@archlinux.org>
Date: Sat, 23 Sep 2017 15:19:25 +0000
Subject: [PATCH] upgpkg: 0.1.1-4

---
 PKGBUILD | 9 +++------
 1 file changed, 3 insertions(+), 6 deletions(-)

diff --git a/PKGBUILD b/PKGBUILD
index 89b3d08..dc592e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
 _hkgname=patience
 pkgname=haskell-patience
 pkgver=0.1.1
-pkgrel=3
+pkgrel=4
 pkgdesc="Patience diff and longest increasing subsequence"
 url="https://hackage.haskell.org/package/${_hkgname}"
 license=("custom:BSD3")
@@ -12,12 +12,12 @@ arch=('i686' 'x86_64')
 depends=('ghc-libs')
 makedepends=('ghc')
 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha256sums=('35c7c334d344b3cbdc61cc88c559bedb300ace860a80e3990aeb268f1f10db63')
+sha512sums=('dac94580d9b82023841b5406509f8cd0e58148756e4259708c21b78b480fb4fb67b21a82c81e702275f49d90bcd1d2b46d20bb96267131d4ff57334f110e14f7')
 
 build() {
     cd "${srcdir}/${_hkgname}-${pkgver}"
     
-    runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
+    runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
         --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
     runhaskell Setup build
@@ -35,7 +35,4 @@ package() {
     runhaskell Setup copy --destdir="${pkgdir}"
     install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
     rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
-
-    # Remove static libs
-    find "$pkgdir"/usr/lib -name "*.a" -delete
 }
-- 
GitLab