diff --git a/PKGBUILD b/PKGBUILD
index f080dd2775c3d510f7f924b04d67da284908648c..808ed996e81e476c3bc80158095c6fb36272032b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
 _hkgname=singleton-bool
 pkgname=haskell-singleton-bool
 pkgver=0.1.6
-pkgrel=3
+pkgrel=4
 pkgdesc="Type level booleans"
 url="https://github.com/phadej/singleton-bool"
 license=('BSD')
@@ -18,7 +18,7 @@ build() {
     
     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
         --prefix=/usr --docdir=/usr/share/doc/$pkgname \
-        --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+        --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
     runhaskell Setup build $MAKEFLAGS
     runhaskell Setup register --gen-script
     runhaskell Setup unregister --gen-script