diff --git a/PKGBUILD b/PKGBUILD
index d946aaaec869df78fc2906af67bc4e863022a1d9..1e87f9e62c43888bf79a2db1308508fff8029214 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
 
 pkgname=httpbin
-pkgver=0.10.0
+pkgver=0.10.1
 pkgrel=1
 pkgdesc="HTTP Request and Response Service"
 arch=('any')
@@ -10,25 +10,25 @@ url="https://github.com/psf/httpbin"
 license=('MIT' 'custom:ISC')
 depends=('python' 'python-flask' 'python-decorator' 'python-six'
          'python-brotlicffi' 'python-werkzeug' 'python-flasgger'
-         # Not directly used. Will be removed in the next upstream version.
-         'python-markupsafe' 'python-itsdangerous' 'python-gevent' 'python-jinja')
+         # Not directly used. TODO: ask upstream if it's really needed
+         'python-greenlet')
 makedepends=('python-setuptools' 'python-build' 'python-installer' 'python-wheel')
 checkdepends=('python-pytest')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/psf/httpbin/archive/v$pkgver.tar.gz")
-sha512sums=('99ff53dae27eb7e50a747cbfcef8381d974f62f79a319fdcda3446fb23bec4e4fea04f7b8e2bac26cfd3b49b229db9659b17166814cdfbbe8b1f2481155b8117')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/psf/httpbin/archive/release-v$pkgver.tar.gz")
+sha512sums=('4fc9551a44de6d2dc9d9d1a430bf6f1be6a5d850397fa69cc02e6ffbd537d1b21f2b47310c770af1070c24b27179b6ccd52b62490003c43de680906e072120c8')
 
 build() {
-  cd httpbin-$pkgver
+  cd httpbin-release-v$pkgver
   python -m build --wheel --no-isolation
 }
 
 check() {
-  cd httpbin-$pkgver
+  cd httpbin-release-v$pkgver
   pytest tests
 }
 
 package() {
-  cd httpbin-$pkgver
+  cd httpbin-release-v$pkgver
   python -m installer --destdir="$pkgdir" dist/*.whl
 
   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE