diff --git a/PKGBUILD b/PKGBUILD
index 9a41cf6411c3785cea0adafc79132ff4908e443e..fb739c5ff04d8445ef0b9c42f10a043d63013216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,13 @@ pkgname=(
   'hyperv'
   'linux-tools-meta'
   'perf'
-#  'python-perf'
   'tmon'
   'turbostat'
   'usbip'
   'x86_energy_perf_policy'
 )
 pkgver=6.3
-pkgrel=1
+pkgrel=2
 license=('GPL2')
 arch=('x86_64')
 url='https://www.kernel.org'
@@ -26,7 +25,8 @@ makedepends=('git')
 # kernel source deps
 makedepends+=('asciidoc' 'xmlto')
 # perf deps
-makedepends+=('perl' 'python' 'python-setuptools' 'slang' 'elfutils' 'libunwind' 'numactl' 'audit' 'zstd' 'libcap')
+makedepends+=('perl' 'python' 'python-setuptools' 'slang' 'elfutils' 'libunwind'
+  'numactl' 'audit' 'zstd' 'libcap' 'libtraceevent' 'openssl' 'clang')
 # cpupower deps
 makedepends+=('pciutils')
 # usbip deps
@@ -75,6 +75,11 @@ prepare() {
     echo ":: Applying patch $src"
     patch -p1 -N -i "$srcdir/$src"
   done
+  # force our perf version
+  cat > tools/perf/util/PERF-VERSION-GEN << EOF
+#!/bin/sh
+echo '#define PERF_VERSION "$pkgver-$pkgrel"' > "\${1:-.}"/PERF-VERSION-FILE
+EOF
 }
 
 build() {
@@ -88,7 +93,6 @@ build() {
     NO_SDT=1 \
     PYTHON=python \
     PYTHON_CONFIG=python-config \
-    PERF_VERSION=$pkgver-$pkgrel \
     DESTDIR="$pkgdir"
   popd
 
@@ -156,7 +160,6 @@ package_linux-tools-meta() {
     'cpupower'
     'hyperv'
     'perf'
-#    'python-perf'
     'tmon'
     'turbostat'
     'usbip'
@@ -171,7 +174,7 @@ package_perf() {
   pkgdesc='Linux kernel performance auditing tool'
   depends=('glibc' 'perl' 'python' 'slang' 'elfutils' 'libunwind' 'binutils'
            'numactl' 'audit' 'coreutils' 'glib2' 'xz' 'zlib' 'libelf' 'bash'
-           'zstd' 'libcap')
+           'zstd' 'libcap' 'libtraceevent' 'openssl')
 
   cd linux/tools/perf
   make -f Makefile.perf \
@@ -182,9 +185,8 @@ package_perf() {
     NO_SDT=1 \
     PYTHON=python \
     PYTHON_CONFIG=python-config \
-    PERF_VERSION=$pkgver-$pkgrel \
     DESTDIR="$pkgdir" \
-    install
+    install install-python_ext
   cd "$pkgdir"
   # add linker search path
   mkdir "$pkgdir/etc/ld.so.conf.d"
@@ -196,16 +198,6 @@ package_perf() {
   find usr/share -type f -exec chmod a-x {} \;
 }
 
-#package_python-perf(){
-#  pkgdesc='Linux kernel performance auditing tool (python bindings)'
-#  depends=('python')
-#
-#  cd linux/tools/perf
-#
-#  make install-python_ext PYTHON=python DESTDIR="$pkgdir"
-#}
-
-
 package_cpupower() {
   pkgdesc='Linux kernel tool to examine and tune power saving related features of your processor'
   backup=('etc/default/cpupower')
@@ -290,7 +282,7 @@ package_hyperv() {
 
 package_bpf() {
   pkgdesc='BPF tools'
-  depends=('glibc' 'readline' 'zlib' 'libelf' 'libcap')
+  depends=('glibc' 'readline' 'zlib' 'libelf' 'libcap' 'zstd' 'llvm-libs' 'binutils')
 
   cd linux/tools/bpf
   # skip runsqlower until disabled in build