diff --git a/PKGBUILD b/PKGBUILD
index 2c00c1277db4149bfb257ad566d36855580e57e0..7f196d54a4a267383556734d63a9b586596f5d71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
 
 pkgname=radare2
 pkgver=5.8.6
-pkgrel=1
+pkgrel=2
 pkgdesc='Open-source tools to disasm, debug, analyze and manipulate binary files'
 url='https://radare.org'
 arch=('x86_64')
@@ -14,9 +14,19 @@ depends=('sh' 'capstone' 'libcapstone.so' 'openssl' 'libzip' 'zlib'
 makedepends=('meson')
 optdepends=('r2ghidra: ghidra decompiler plugin')
 options=('!emptydirs')
-source=(https://github.com/radare/radare2/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
-sha512sums=('cd53ed7519d485253182d8d7d414b8d0927e65dd4d0c9716d0d8819e739c8e5e39deb702d93cb5a2a9425804d9798e6eb0acb58a4b904e25a9ba4fcad2315f47')
-b2sums=('da53500982894a84de0a60640622b6498d3a6cc5236d7141cbd400b76448dc53535c74eef620e13531965c855124065a7f8ccfc3d8622c4e366100dc777e5274')
+source=(https://github.com/radare/radare2/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
+        wasm.patch)
+sha512sums=('cd53ed7519d485253182d8d7d414b8d0927e65dd4d0c9716d0d8819e739c8e5e39deb702d93cb5a2a9425804d9798e6eb0acb58a4b904e25a9ba4fcad2315f47'
+            '77728bc0d2cd0eb383ea845923e02bed7e8ce19e2cd7d7170d40eb91a37f85ed8582bf3331dd85be441131c68663782b2acd53192dd2d3dc6e1866c1c916b666')
+b2sums=('da53500982894a84de0a60640622b6498d3a6cc5236d7141cbd400b76448dc53535c74eef620e13531965c855124065a7f8ccfc3d8622c4e366100dc777e5274'
+        'bbe9118239735e513beab1c8ebc01c2e5330b0f6aba033e25f2e139a21b4c6188690a22cd7742b4e89bc750b309ec27ddb80b33933bb64e0fd704ef36d59989f')
+
+prepare() {
+  cd ${pkgname}-${pkgver}
+# Add wasm to the default plugin list. There is currently no way to append a single plugin to the default list via the meson command line
+# https://github.com/radareorg/radare2/discussions/21712#discussioncomment-5826108
+  patch -p1 -i ../wasm.patch
+}
 
 build() {
   cd ${pkgname}-${pkgver}
diff --git a/wasm.patch b/wasm.patch
new file mode 100644
index 0000000000000000000000000000000000000000..f9315129e6be374864dc32bca5bb6aea8ce572f7
--- /dev/null
+++ b/wasm.patch
@@ -0,0 +1,12 @@
+diff --git a/libr/meson.build b/libr/meson.build
+index 7251e43125..ef3722b619 100644
+--- a/libr/meson.build
++++ b/libr/meson.build
+@@ -47,6 +47,7 @@ arch_plugins = [ 'null',
+   'cris',
+   'cr16',
+   'bf',
++  'wasm',
+ ]
+ bin_plugins = [ 'any' ]
+ bin_ldr_plugins = [ 'ldr_linux' ]