diff --git a/PKGBUILD b/PKGBUILD
index 670ae8f18d1f3597d3aa4871f69d82828145a009..22d3184afbe2de2fc42aabbf067dc0bd45ba9d16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
 # Contributor: korjjj <korjjj+aur@gmail.com>
 
 pkgname=syncthing
-pkgver=0.11.26
+pkgver=0.12.0
 pkgrel=1
 pkgdesc="Open Source Continuous Replication / Cluster Synchronization Thing"
+arch=('i686' 'x86_64')
 url="http://syncthing.net/"
 license=('MPL')
-arch=('i686' 'x86_64')
 depends=('glibc')
 makedepends=('git' 'go' 'godep' 'inetutils' 'sed')
+install=$pkgname.install
 source=($pkgname-$pkgver::git+https://github.com/syncthing/syncthing.git#tag=v${pkgver})
 sha1sums=('SKIP')
 
@@ -37,7 +38,7 @@ build() {
 check() {
   export GOPATH="${srcdir}"
   cd "${srcdir}/src/github.com/syncthing/${pkgname}"
-#  go run build.go -no-upgrade test
+  #go run build.go -no-upgrade test
 }
 
 package() {
diff --git a/syncthing.install b/syncthing.install
new file mode 100644
index 0000000000000000000000000000000000000000..9821356a04f91c050d382d911410d5746167788c
--- /dev/null
+++ b/syncthing.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+  if (( "$(vercmp $2 0.12.0-1)" < 0 )); then
+    cat << EOF
+  This is the first release on the new major v0.12 branch. It is not
+  compatible with the v0.11.x releases! Use this release if you are
+  a new user, or when you are ready to upgrade all devices in your cluster.
+  Full information is available on the release page
+  https://forum.syncthing.net/t/syncthing-v0-12-0-beryllium-bedbug/6026
+
+EOF
+  fi
+}