Unverified Commit f65025ba authored by Santiago Torres's avatar Santiago Torres
Browse files

FIX:fix docker build commands

I commited the wrong Dockerfile.
parent 602cda86
FROM scratch
ADD archlinux.tar /
RUN update-ca-certs
RUN locale-gen
RUN pacman-key --init && pacman-key --populate archlinux
RUN /usr/share/libalpm/scripts/systemd-hook sysusers
# manually run all alpm hooks that can't be run inside the fakechroot
RUN ldconfig && update-ca-trust && locale-gen && /usr/share/libalpm/scripts/systemd-hook sysusers && pacman-key --init && pacman-key --populate archlinux
ENV LANG=en_US.UTF-8
CMD ["/usr/bin/bash"]
......@@ -12,7 +12,7 @@ rootfs: hooks
mkdir -vp $(BUILDDIR)/var/lib/pacman/
fakechroot -- fakeroot -- pacman -Sy -r $(BUILDDIR) \
--noconfirm --dbpath $(PWD)/$(BUILDDIR)/var/lib/pacman \
--config rootfs/etc/pacman.conf \
--config pacman.conf \
--noscriptlet \
--hookdir $(PWD)/alpm-hooks/usr/share/libalpm/hooks/ $(shell cat packages)
cp --recursive --preserve=timestamps --backup --suffix=.pacnew rootfs/* $(BUILDDIR)/
......
......@@ -76,7 +76,7 @@ Include = rootfs/etc/pacman.d/mirrorlist
Include = rootfs/etc/pacman.d/mirrorlist
[community]
Include = rootfs//etc/pacman.d/mirrorlist
Include = rootfs/etc/pacman.d/mirrorlist
# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment