Verified Commit cfa95ef8 authored by Kevin Morris's avatar Kevin Morris
Browse files

RPC: add deprecation warning for v1-v4 usage



With FastAPI starting to come closer to a close, we've got to advertise
this deprecation so that users have some time to adjust before making
the changes. We have not specified a specific time here, but we'd like
this message to reach users of the RPC API for at least a month before
any modifications are made to the interface.
Signed-off-by: Kevin Morris's avatarKevin Morris <kevr@0cost.org>
parent 565f6247
Pipeline #10812 passed with stage
in 51 seconds
......@@ -272,6 +272,15 @@ class AurJSON {
'results' => $data
);
if ($this->version != 5) {
$json_array['warning'] = 'The use of versions lower than 5 is '
. 'now deprecated and will soon be unsupported. To ensure '
. 'your API client supports the change without issue, it '
. 'should use version 5 and adjust for any changes in the '
. 'API interface. See https://aur.archlinux.org/rpc for '
. 'documentation related to v5.';
}
if ($error) {
$json_array['error'] = $error;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment