Verified Commit e847c4ad authored by nl6720's avatar nl6720
Browse files

.gitlab/ci/build-host.sh: Do not upgrade packages with files in /usr/lib/modules/

Packages with files in /usr/lib/modules/ depend on the current kernel, thus they should not be updated.
parent 6bb12552
...@@ -140,7 +140,7 @@ function main() { ...@@ -140,7 +140,7 @@ function main() {
expect "# " expect "# "
# Install required packages # Install required packages
send "pacman -Syu --ignore linux --noconfirm --needed qemu-headless jq dosfstools e2fsprogs libisoburn mtools squashfs-tools zsync\n" send "pacman -Fy && pacman -Syu --ignore \$(pacman -Fq --machinereadable /usr/lib/modules/ | awk 'BEGIN { FS = \"\\\0\";ORS=\",\" }; { print \$2 } ' | sort -ut , | head -c -2) --noconfirm --needed qemu-headless jq dosfstools e2fsprogs libisoburn mtools squashfs-tools zsync\n"
expect "# " 120 expect "# " 120
## Start build and copy output to local disk ## Start build and copy output to local disk
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment