Skip to content
Snippets Groups Projects
Verified Commit 36ae1baf authored by Balló György's avatar Balló György :flag_hu:
Browse files

upgpkg: 46.0-3: Add decibels package

parents
No related branches found
No related tags found
No related merge requests found
.SRCINFO 0 → 100644
pkgbase = decibels
pkgdesc = Audio player for GNOME
pkgver = 46.0
pkgrel = 3
url = https://apps.gnome.org/Decibels/
arch = any
license = GPL-3.0-or-later
makedepends = appstream
makedepends = blueprint-compiler
makedepends = git
makedepends = meson
makedepends = typescript
depends = dconf
depends = gjs
depends = glib2
depends = graphene
depends = gst-plugins-bad-libs
depends = gst-plugins-base
depends = gst-plugins-base-libs
depends = gst-plugins-good
depends = gstreamer
depends = gtk4
depends = hicolor-icon-theme
depends = libadwaita
optdepends = gst-libav: Extra media codecs
optdepends = gst-plugins-bad: Extra media codecs
optdepends = gst-plugins-ugly: Extra media codecs
source = git+https://gitlab.gnome.org/GNOME/Incubator/decibels.git#tag=46.0
source = git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git
source = decibels-window-icon.patch
b2sums = f254bc63f38fa6f1ec43ba4ab24725e5550ad82db7a9a8db64c185e95dcb2b6a962ebded9e822892fbc86e9c3bf5ae581ba52d46ea790e9ee1a3952c628808ba
b2sums = SKIP
b2sums = a88e09698d10498d2ece45dee2ea27cbdb6e0b6ab238a34b048e4eb76b8ba6ca5bfe9f2ab712a0473cd46c656a186c54e22bd2eec590de73e7aeddcca60228e5
pkgname = decibels
[decibels]
source = "git"
git = "https://gitlab.gnome.org/GNOME/Incubator/decibels.git"
PKGBUILD 0 → 100644
# Maintainer: Balló György <ballogyor+arch at gmail dot com>
pkgname=decibels
pkgver=46.0
pkgrel=3
pkgdesc='Audio player for GNOME'
arch=(any)
url='https://apps.gnome.org/Decibels/'
license=(GPL-3.0-or-later)
depends=(
dconf
gjs
glib2
graphene
gst-plugins-bad-libs
gst-plugins-base
gst-plugins-base-libs
gst-plugins-good
gstreamer
gtk4
hicolor-icon-theme
libadwaita
)
makedepends=(
appstream
blueprint-compiler
git
meson
typescript
)
optdepends=(
'gst-libav: Extra media codecs'
'gst-plugins-bad: Extra media codecs'
'gst-plugins-ugly: Extra media codecs'
)
source=(
"git+https://gitlab.gnome.org/GNOME/Incubator/decibels.git#tag=$pkgver"
git+https://gitlab.gnome.org/BrainBlasted/gi-typescript-definitions.git
decibels-window-icon.patch
)
b2sums=(
f254bc63f38fa6f1ec43ba4ab24725e5550ad82db7a9a8db64c185e95dcb2b6a962ebded9e822892fbc86e9c3bf5ae581ba52d46ea790e9ee1a3952c628808ba
SKIP
a88e09698d10498d2ece45dee2ea27cbdb6e0b6ab238a34b048e4eb76b8ba6ca5bfe9f2ab712a0473cd46c656a186c54e22bd2eec590de73e7aeddcca60228e5
)
prepare() {
cd $pkgname
git submodule init
git submodule set-url gi-types "$srcdir/gi-typescript-definitions"
git -c protocol.file.allow=always submodule update
# https://gitlab.gnome.org/GNOME/Incubator/decibels/-/merge_requests/123
git apply -3 ../decibels-window-icon.patch
}
build() {
arch-meson $pkgname build
meson compile -C build
}
check() {
meson test -C build --print-errorlogs
}
package() {
meson install -C build --destdir "$pkgdir"
ln -s org.gnome.Decibels "$pkgdir/usr/bin/decibels"
}
From 7e9685bdb39187510f3899fcec6acd4a0caf2820 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
Date: Fri, 20 Sep 2024 11:07:30 +0000
Subject: [PATCH] application: Set icon for the window
This is commonly used by desktop environments on Xorg.
---
src/application.ts | 2 ++
1 file changed, 2 insertions(+)
diff --git a/src/application.ts b/src/application.ts
index c6533f2..02d27f8 100644
--- a/src/application.ts
+++ b/src/application.ts
@@ -21,6 +21,8 @@ export class Application extends Adw.Application {
flags: Gio.ApplicationFlags.HANDLES_OPEN,
});
+ Gtk.Window.set_default_icon_name(pkg.name);
+
const quit_action = new Gio.SimpleAction({ name: "quit" });
quit_action.connect("activate", () => {
this.quit();
--
GitLab
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment