Skip to content
Snippets Groups Projects
Verified Commit 050df7af authored by Antonio Rojas's avatar Antonio Rojas
Browse files

upgpkg: 5.9.13-2: Qt 5.15.11 rebuild

parent 2fde96a6
No related branches found
No related tags found
No related merge requests found
.SRCINFO 0 → 100644
pkgbase = deepin-image-viewer
pkgdesc = An image viewing tool with fashion interface and smooth performance
pkgver = 5.9.13
pkgrel = 2
url = https://github.com/linuxdeepin/deepin-image-viewer
arch = x86_64
groups = deepin
license = GPL3
makedepends = cmake
makedepends = ninja
makedepends = qt5-tools
depends = deepin-qt5integration
depends = qt5-base
depends = dtkcore
depends = dtkgui
depends = dtkwidget
depends = deepin-image-editor
depends = gcc-libs
depends = libraw
optdepends = deepin-manual: for help manual
optdepends = deepin-shortcut-viewer: for shortcut display
source = https://github.com/linuxdeepin/deepin-image-viewer/archive/5.9.13/deepin-image-viewer-5.9.13.tar.gz
source = libraw-0.21.patch
source = qt-5.15.11.patch
sha512sums = a6112c1dba0b20ff762933a0606798a95ba8121758adcc803b86bf418f486a13f3a584ee267c4d0709997e8b60b191187b76a9b6983af7828cfb7e9c6aceaf0a
sha512sums = 37587172bb74d6e243ae34120f6d0f27c5aa0ce46fc3faf53878c2827811ba922370820c62715f406bbfe9ebf14dbfc0042b85dc0ee7c51c3a4da08d840b7fd4
sha512sums = 80eed1be01595f7828ab05a8fe1aca68d5ca91fef01c299f0ccbbf0398a4ecbdeee5a2fefbc3d5219a0a0bd6e4e3e1a204339b1e7ea5f652cfb91291f351786c
pkgname = deepin-image-viewer
......@@ -14,14 +14,17 @@ optdepends=('deepin-manual: for help manual'
'deepin-shortcut-viewer: for shortcut display')
groups=('deepin')
source=("https://github.com/linuxdeepin/deepin-image-viewer/archive/$pkgver/$pkgname-$pkgver.tar.gz"
libraw-0.21.patch)
libraw-0.21.patch
qt-5.15.11.patch)
sha512sums=('a6112c1dba0b20ff762933a0606798a95ba8121758adcc803b86bf418f486a13f3a584ee267c4d0709997e8b60b191187b76a9b6983af7828cfb7e9c6aceaf0a'
'37587172bb74d6e243ae34120f6d0f27c5aa0ce46fc3faf53878c2827811ba922370820c62715f406bbfe9ebf14dbfc0042b85dc0ee7c51c3a4da08d840b7fd4')
'37587172bb74d6e243ae34120f6d0f27c5aa0ce46fc3faf53878c2827811ba922370820c62715f406bbfe9ebf14dbfc0042b85dc0ee7c51c3a4da08d840b7fd4'
'80eed1be01595f7828ab05a8fe1aca68d5ca91fef01c299f0ccbbf0398a4ecbdeee5a2fefbc3d5219a0a0bd6e4e3e1a204339b1e7ea5f652cfb91291f351786c')
prepare() {
cd deepin-image-viewer-$pkgver
sed -i -e 's|qt5/plugins|qt/plugins|' -e 's|${Qt5Core_DIR}|/usr/lib/cmake/Qt5Core|' qimage-plugins/libraw/CMakeLists.txt
patch -p1 < ../libraw-0.21.patch # Fix build with libraw 0.21
patch -p1 < ../qt-5.15.11.patch # Fix build with Qt 5.15.11
}
build() {
......
diff --git a/src/src/main.cpp b/src/src/main.cpp
index ce87085e..e26600c6 100644
--- a/src/src/main.cpp
+++ b/src/src/main.cpp
@@ -24,6 +24,9 @@
#include <QDesktopWidget>
#include <QScreen>
#include <QtDBus/QDBusConnection>
+#include <QDir>
+#include <QFileInfo>
+#include <QProcessEnvironment>
#include <sys/types.h>
#include <sys/stat.h>
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment