Skip to content
Snippets Groups Projects
Commit 07fa9530 authored by Balló György's avatar Balló György :flag_hu:
Browse files

Build with OpenSSL 1.1 and backup all config files (FS#64079)

parent dbc3a811
No related branches found
Tags 1.26.0-2
No related merge requests found
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: dorphell <dorphell@archlinux.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=dillo
pkgver=3.0.5
pkgrel=9
pkgrel=10
pkgdesc="A small, fast graphical web browser built on FLTK"
arch=(x86_64)
url="https://www.dillo.org"
license=('GPL')
depends=('fltk' 'libjpeg' 'perl' 'libpng' 'gcc-libs' 'libxcursor'
'libxi' 'libxinerama' 'openssl-1.0')
backup=(etc/dillo/{dillorc,dpidrc})
depends=('fltk' 'libjpeg' 'libpng' 'openssl' 'perl' 'zlib')
backup=(etc/dillo/{dillorc,domainrc,dpidrc,keysrc})
validpgpkeys=('D91CE08D8679CF2A6F8792E05B1004E936929CEE')
source=(https://www.dillo.org/download/$pkgname-$pkgver.tar.bz2{,.asc}
openssl.patch
dillo.desktop
https://www.dillo.org/Icons/ProgramIcon128.png)
sha256sums=('db1be16c1c5842ebe07b419aa7c6ef11a45603a75df2877f99635f4f8345148b'
'SKIP'
'54848080de1911a2af8ff786fbe92bdad8fe8b7b8a0d580c9c79b0a98f9fdcde'
'ddd097b30b95a5ac5638f57d04dc2e421d5c2fa3d0985747921e1bfc5b55fb23'
'e94ead3a359c2eceb934b07af0fac4864251b9721fa7f4855331daa017b66202'
'72ecb57983117b17f0777caf6cf935a2ad5d72aca7b07b11f5b75562cb420778')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -Np1 -i ../openssl.patch
autoreconf -fi
}
build() {
cd "$srcdir/$pkgname-$pkgver"
CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
CFLAGS+=" -I/usr/include/openssl-1.0" LDFLAGS+=" -L/usr/lib/openssl-1.0" \
./configure --prefix=/usr --sysconfdir=/etc --enable-cookies --enable-dlgui \
--enable-ssl
./configure --prefix=/usr --sysconfdir=/etc --enable-cookies --enable-ssl
make
}
......
......@@ -2,8 +2,9 @@
Name=Dillo
GenericName=Web Browser
Comment=Very small and fast GUI web browser
Exec=dillo
Exec=dillo %U
Icon=dillo
Terminal=false
Type=Application
Categories=Network;GTK;WebBrowser;
Categories=Network;WebBrowser;
MimeType=text/html;application/xhtml+xml;
Description: Fix OpenSSL 1.1 detection and access to now opaque structures.
Bug-Debian: https://bugs.debian.org/845035
Author: Axel Beckert <abe@debian.org>
Forwarded: http://lists.dillo.org/pipermail/dillo-dev/2017-September/011076.html
--- a/configure.ac
+++ b/configure.ac
@@ -286,7 +286,7 @@
if test "x$ssl_ok" = "xyes"; then
old_libs="$LIBS"
- AC_CHECK_LIB(ssl, SSL_library_init, ssl_ok=yes, ssl_ok=no, -lcrypto)
+ AC_CHECK_LIB(ssl, SSL_new, ssl_ok=yes, ssl_ok=no, -lcrypto)
LIBS="$old_libs"
fi
--- a/dpi/https.c
+++ b/dpi/https.c
@@ -476,7 +476,7 @@
case X509_V_ERR_DEPTH_ZERO_SELF_SIGNED_CERT:
/*Either self signed and untrusted*/
/*Extract CN from certificate name information*/
- if ((cn = strstr(remote_cert->name, "/CN=")) == NULL) {
+ if ((cn = strstr(X509_get_subject_name((X509 *) remote_cert), "/CN=")) == NULL) {
strcpy(buf, "(no CN given)");
} else {
char *cn_end;
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment