Skip to content
Snippets Groups Projects
Commit 730c20aa authored by Ionuț Mircea Bîru's avatar Ionuț Mircea Bîru
Browse files

update to 4.0rc1

parent 376e2331
No related branches found
No related tags found
No related merge requests found
# Contributor: Jakub Schmidtke <sjakub@gmail.com> # Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox pkgname=firefox
pkgver=3.6.15 pkgver=4.0rc1
pkgrel=1 pkgrel=1
_xulver=1.9.2.15 _xulver=2.0rc1
pkgdesc="Standalone web browser from mozilla.org" pkgdesc="Standalone web browser from mozilla.org"
arch=('i686' 'x86_64') arch=('i686' 'x86_64')
license=('MPL' 'GPL' 'LGPL') license=('MPL' 'GPL' 'LGPL')
depends=("xulrunner=${_xulver}" 'desktop-file-utils') depends=("xulrunner=${_xulver}" 'desktop-file-utils')
makedepends=('zip' 'pkg-config' 'diffutils' 'libgnomeui>=2.24.1' 'python2' 'wireless_tools' 'autoconf2.13') makedepends=('zip' 'pkg-config' 'diffutils' 'libgnomeui' 'python2' 'wireless_tools' 'yasm' 'mesa')
install=firefox.install install=firefox.install
url="http://www.mozilla.org/projects/firefox" url="http://www.mozilla.org/projects/firefox"
source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}.source.tar.bz2 source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/source/firefox-${pkgver}.source.tar.bz2
...@@ -17,40 +17,36 @@ source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/s ...@@ -17,40 +17,36 @@ source=(http://releases.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}/s
firefox-safe.desktop firefox-safe.desktop
mozilla-firefox-1.0-lang.patch mozilla-firefox-1.0-lang.patch
browser-defaulturls.patch browser-defaulturls.patch
firefox-version.patch firefox-version.patch)
firefox-agent.patch md5sums=('511828dcc226f38602c6c67bd192ef40'
python2.7.patch) '250ea468715b9c0dd65ce9544e4413ce'
md5sums=('fcf8042948d91f1f3d9c33599b79cf35'
'ca385167401b98ef7adc6529e4b53205'
'bdeb0380c7fae30dd0ead6d2d3bc5873' 'bdeb0380c7fae30dd0ead6d2d3bc5873'
'6f38a5899034b7786cb1f75ad42032b8' '6f38a5899034b7786cb1f75ad42032b8'
'bd5db57c23c72a02a489592644f18995' 'bd5db57c23c72a02a489592644f18995'
'1807651225b021e043154f8bba715a19' '099d61174d2a08951ea1d083d7684fa5'
'92c11c66dd69b03f214002fededd1fc8' 'cea73894617d0e12362db294864fb87f')
'f437e94acff8f810991271ef4677d859'
'ab3dc9aecae7f08b9492fb3c00a5fd28')
build() { build() {
cd "${srcdir}/mozilla-1.9.2" cd "${srcdir}/mozilla-2.0"
patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch" patch -Np1 -i "${srcdir}/mozilla-firefox-1.0-lang.patch"
patch -Np1 -i "${srcdir}/browser-defaulturls.patch" patch -Np1 -i "${srcdir}/browser-defaulturls.patch"
patch -Np1 -i "${srcdir}/firefox-version.patch" patch -Np1 -i "${srcdir}/firefox-version.patch"
patch -Np1 -i "${srcdir}/firefox-agent.patch"
patch -Np0 -i "${srcdir}/python2.7.patch"
cp "${srcdir}/mozconfig" .mozconfig cp "${srcdir}/mozconfig" .mozconfig
unset CFLAGS unset CFLAGS
unset CXXFLAGS unset CXXFLAGS
export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-3.6" export LDFLAGS="-Wl,-rpath,/usr/lib/firefox-4.0"
make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}" make -j1 -f client.mk build MOZ_MAKE_FLAGS="${MAKEFLAGS}"
make -j1 DESTDIR="${pkgdir}" install }
rm -f ${pkgdir}/usr/lib/firefox-3.6/libjemalloc.so package() {
cd "${srcdir}/mozilla-2.0"
make -j1 -f client.mk DESTDIR="${pkgdir}" install
install -m755 -d ${pkgdir}/usr/share/{applications,pixmaps} install -m755 -d ${pkgdir}/usr/share/{applications,pixmaps}
install -m644 ${srcdir}/mozilla-1.9.2/browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png install -m644 browser/branding/unofficial/default48.png ${pkgdir}/usr/share/pixmaps/firefox.png
install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/ install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/ install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/
} }
diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties diff -Nur mozilla-2.0.orig//browser/branding/unofficial/pref/firefox-branding.js mozilla-2.0/browser/branding/unofficial/pref/firefox-branding.js
--- mozilla-1.9.2.old//browser/branding/unofficial/locales/browserconfig.properties 2010-04-14 01:21:35.000000000 +0300 --- mozilla-2.0.orig//browser/branding/unofficial/pref/firefox-branding.js 2011-03-03 14:11:19.000000000 -0800
+++ mozilla-1.9.2/browser/branding/unofficial/locales/browserconfig.properties 2010-04-20 23:55:32.036959438 +0300 +++ mozilla-2.0/browser/branding/unofficial/pref/firefox-branding.js 2011-03-13 10:02:02.950027389 -0700
@@ -1,3 +1,3 @@ @@ -1,5 +1,6 @@
# Do NOT localize or otherwise change these values
-browser.startup.homepage=http://www.mozilla.org/projects/namoroka/
+browser.startup.homepage=http://www.google.com/firefox
diff -Nur mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js
--- mozilla-1.9.2.old//browser/branding/unofficial/pref/firefox-branding.js 2010-04-14 01:21:35.000000000 +0300
+++ mozilla-1.9.2/browser/branding/unofficial/pref/firefox-branding.js 2010-04-20 23:55:01.290102941 +0300
@@ -1,5 +1,5 @@
-pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/"); -pref("startup.homepage_override_url","http://www.mozilla.org/projects/%APP%/%VERSION%/whatsnew/");
-pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/"); -pref("startup.homepage_welcome_url","http://www.mozilla.org/projects/%APP%/%VERSION%/firstrun/");
+pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/"); +pref("startup.homepage_override_url","http://www.mozilla.com/%APP%/%VERSION%/whatsnew/");
+
+pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/"); +pref("startup.homepage_welcome_url","http://www.mozilla.com/%APP%/%VERSION%/firstrun/");
pref("browser.panorama.welcome_url", "http://www.mozilla.com/firefox/panorama/");
// The time interval between checks for a new version (in seconds) // The time interval between checks for a new version (in seconds)
// nightly=8 hours, official=24 hours // nightly=8 hours, official=24 hours
pref("app.update.interval", 28800); @@ -15,7 +16,7 @@
@@ -14,7 +14,7 @@
pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/"); pref("app.update.url.details", "http://www.mozilla.org/projects/%APP%/");
// Release notes URL // Release notes and vendor URLs
-pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/"); -pref("app.releaseNotesURL", "http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/");
+pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/"); +pref("app.releaseNotesURL", "http://www.mozilla.com/%APP%/%VERSION%/releasenotes/");
pref("app.vendorURL", "http://www.mozilla.org/projects/%APP%/");
// Search codes belong only in builds with official branding // Search codes belong only in builds with official branding
pref("browser.search.param.yahoo-fr", "");
diff -Nur mozilla-1.9.2.orig/browser/app/profile/firefox.js mozilla-1.9.2/browser/app/profile/firefox.js
--- mozilla-1.9.2.orig/browser/app/profile/firefox.js 2010-04-14 01:21:35.000000000 +0300
+++ mozilla-1.9.2/browser/app/profile/firefox.js 2010-04-21 00:16:59.673528609 +0300
@@ -183,7 +183,7 @@
pref("general.useragent.locale", "@AB_CD@");
pref("general.skins.selectedSkin", "classic/1.0");
-pref("general.useragent.extra.firefox", "@APP_UA_NAME@/@APP_VERSION@");
+pref("general.useragent.extra.firefox", "Firefox/@APP_VERSION@");
pref("general.smoothScroll", false);
#ifdef UNIX_BUT_NOT_MAC
--- mozilla-1.9.1/browser/installer/Makefile.in.ver 2009-07-18 13:32:35.000000000 +0200 diff -Nur mozilla-2.0.orig//browser/installer/Makefile.in mozilla-2.0/browser/installer/Makefile.in
+++ mozilla-1.9.1/browser/installer/Makefile.in 2009-07-18 13:33:12.000000000 +0200 --- mozilla-2.0.orig//browser/installer/Makefile.in 2011-03-03 14:11:20.000000000 -0800
+++ mozilla-2.0/browser/installer/Makefile.in 2011-03-13 10:08:45.896702838 -0700
@@ -43,6 +43,8 @@ @@ -43,6 +43,8 @@
include $(DEPTH)/config/autoconf.mk include $(DEPTH)/config/autoconf.mk
+MOZ_APP_VERSION="3.6" +MOZ_APP_VERSION="4.0"
+ +
NO_PKG_FILES = \ include $(topsrcdir)/config/rules.mk
$(MOZ_APP_NAME)-config \
$(MOZ_APP_NAME)-bin.elf \ MOZ_PKG_REMOVALS = $(srcdir)/removed-files.in
...@@ -6,31 +6,52 @@ ac_add_options --with-system-nspr ...@@ -6,31 +6,52 @@ ac_add_options --with-system-nspr
ac_add_options --with-system-nss ac_add_options --with-system-nss
ac_add_options --with-system-jpeg ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib ac_add_options --with-system-zlib
ac_add_options --with-system-bz2
ac_add_options --with-system-png ac_add_options --with-system-png
ac_add_options --with-system-libevent
ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite
ac_add_options --enable-system-cairo
ac_add_options --with-pthreads ac_add_options --with-pthreads
ac_add_options --enable-strip
ac_add_options --enable-install-strip
ac_add_options --disable-tests ac_add_options --disable-tests
ac_add_options --disable-mochitest
ac_add_options --disable-installer
ac_add_options --disable-pedantic
ac_add_options --enable-jemalloc
ac_add_options --enable-xterm-updates
ac_add_options --disable-debug ac_add_options --disable-debug
ac_add_options --enable-optimize ac_add_options --enable-optimize
ac_add_options --disable-installer ac_add_options --enable-printing
ac_add_options --enable-xinerama ac_add_options --enable-xinerama
ac_add_options --enable-places
ac_add_options --enable-default-toolkit=cairo-gtk2 ac_add_options --enable-default-toolkit=cairo-gtk2
ac_add_options --disable-xprint ac_add_options --disable-xprint
ac_add_options --enable-strip
ac_add_options --enable-pango ac_add_options --enable-pango
#ac_add_options --enable-system-cairo
ac_add_options --enable-svg ac_add_options --enable-svg
ac_add_options --enable-canvas ac_add_options --enable-canvas
ac_add_options --enable-startup-notification ac_add_options --enable-startup-notification
ac_add_options --enable-libxul ac_add_options --disable-javaxpcom
ac_add_options --disable-crashreporter ac_add_options --disable-crashreporter
ac_add_options --disable-updater ac_add_options --disable-updater
ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-1.9.2
ac_add_options --enable-safe-browsing ac_add_options --enable-safe-browsing
ac_add_options --enable-extensions=default
ac_add_options --enable-smil
ac_add_options --enable-canvas3d
ac_add_options --enable-url-classifier
ac_add_options --enable-libxul
ac_add_options --with-libxul-sdk=/usr/lib/xulrunner-devel-2.0
ac_add_options --with-branding=browser/branding/unofficial ac_add_options --with-branding=browser/branding/unofficial
ac_add_options --enable-gio
ac_add_options --enable-gnomevfs
ac_add_options --enable-gnomeui
ac_add_options --enable-gconf
ac_add_options --enable-libnotify
export BUILD_OFFICIAL=1 export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1 export MOZILLA_OFFICIAL=1
export USE_SHORT_LIBNAME=1
mk_add_options BUILD_OFFICIAL=1 mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1 mk_add_options MOZILLA_OFFICIAL=1
mk_add_options USE_SHORT_LIBNAME=1
--- configure.in 2010-10-12 10:44:37.000000000 -0700
+++ configure.in~ 2010-10-19 09:51:49.660019364 -0700
@@ -811,7 +811,7 @@
AC_MSG_RESULT([yes])
fi
-MOZ_PATH_PROGS(PYTHON, $PYTHON python2.5 python2.4 python)
+MOZ_PATH_PROGS(PYTHON, $PYTHON python2.7 python2.5 python2.4 python)
if test -z "$PYTHON"; then
AC_MSG_ERROR([python was not found in \$PATH])
fi
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment