Skip to content
Snippets Groups Projects
Commit df7a041d authored by Jan Alexander Steffens (heftig)'s avatar Jan Alexander Steffens (heftig)
Browse files

54.0-1

parent 8095ccca
No related branches found
No related tags found
No related merge requests found
From bbd48a5613c872883616884cfaf41665b0e4ec9b Mon Sep 17 00:00:00 2001
From: Ralph Giles <giles@mozilla.com>
Date: Fri, 10 Feb 2017 12:58:18 -0800
Subject: [PATCH] Bug 1338655 - Don't try to build mp4parse bindings. r=froydnj
We use the cheddar crate to generate a C header file
for our mp4parse_capi wrapper crate. Currently we
do this at code check-in time via update-rust.sh.
Cargo 0.18 and later will try to execute a build.rs
file in the crate source tree regardless of whether
it's specified in Cargo.toml so patching out that
line just results in 'crate cheddar not found'.
This change restores the old behaviour by substituting
a 'build = false' line instead.
We do have syntex vendored, but we don't currently build
it by default, so I prefer this solution to just vendoring
cheddar and generating the header at build time. The syntex
crate is quite large and adds significantly to our compile
time.
MozReview-Commit-ID: InJRRODWAdP
--HG--
extra : rebase_source : 29378fcbc86015ce6cc22dc66d38a43ddbac204e
---
media/libstagefright/binding/mp4parse-cargo.patch | 5 +++--
media/libstagefright/binding/mp4parse_capi/Cargo.toml | 2 ++
2 files changed, 5 insertions(+), 2 deletions(-)
diff --git a/media/libstagefright/binding/mp4parse_capi/Cargo.toml b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
index aee7ee947151a27c..d7e3f55119d3f4b6 100644
--- a/media/libstagefright/binding/mp4parse_capi/Cargo.toml
+++ b/media/libstagefright/binding/mp4parse_capi/Cargo.toml
@@ -18,6 +18,8 @@ exclude = [
"*.mp4",
]
+build = false
+
[dependencies]
byteorder = "1.0.0"
"mp4parse" = {version = "0.6.0", path = "../mp4parse"}
--
2.12.2
...@@ -3,30 +3,30 @@ ...@@ -3,30 +3,30 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com> # Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=firefox pkgname=firefox
pkgver=53.0.3 pkgver=54.0
pkgrel=1 pkgrel=1
pkgdesc="Standalone web browser from mozilla.org" pkgdesc="Standalone web browser from mozilla.org"
arch=(i686 x86_64) arch=(i686 x86_64)
license=(MPL GPL LGPL) license=(MPL GPL LGPL)
url="https://www.mozilla.org/firefox/" url="https://www.mozilla.org/firefox/"
depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg depends=(gtk3 gtk2 mozilla-common libxt startup-notification mime-types dbus-glib alsa-lib ffmpeg
libvpx libevent nss hunspell sqlite ttf-font icu) nss hunspell sqlite ttf-font libpulse icu libvpx)
makedepends=(unzip zip diffutils python2 yasm mesa imake gconf libpulse inetutils xorg-server-xvfb makedepends=(unzip zip diffutils python2 yasm mesa imake gconf inetutils xorg-server-xvfb
autoconf2.13 cargo mercurial) autoconf2.13 cargo mercurial)
optdepends=('networkmanager: Location detection via available WiFi networks' optdepends=('networkmanager: Location detection via available WiFi networks'
'libnotify: Notification integration' 'libnotify: Notification integration'
'pulseaudio: Audio support'
'speech-dispatcher: Text-to-Speech') 'speech-dispatcher: Text-to-Speech')
options=(!emptydirs !makeflags !strip) options=(!emptydirs !makeflags !strip)
_repo=https://hg.mozilla.org/mozilla-unified _repo=https://hg.mozilla.org/mozilla-unified
source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE" source=("hg+$_repo#tag=FIREFOX_${pkgver//./_}_RELEASE"
firefox.desktop firefox-symbolic.svg $pkgname.desktop firefox-symbolic.svg
0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch firefox-install-dir.patch no-crmf.diff fix-wifi-scanner.diff)
firefox-install-dir.patch fix-wifi-scanner.diff)
sha256sums=('SKIP' sha256sums=('SKIP'
'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef' 'ada313750e6fb14558b37c764409a17c1672a351a46c73b350aa1fe4ea9220ef'
'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9' 'a2474b32b9b2d7e0fb53a4c89715507ad1c194bef77713d798fa39d507def9e9'
'413cd6d366d78f325d80ebebccfd0afa0d266b40b2e54b66ba2fa03c15f3ea67'
'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd' 'd86e41d87363656ee62e12543e2f5181aadcff448e406ef3218e91865ae775cd'
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
'9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8') '9765bca5d63fb5525bbd0520b7ab1d27cabaed697e2fc7791400abc3fa4f13b8')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys) # Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
...@@ -48,12 +48,12 @@ prepare() { ...@@ -48,12 +48,12 @@ prepare() {
cd mozilla-unified cd mozilla-unified
patch -Np1 -i ../firefox-install-dir.patch patch -Np1 -i ../firefox-install-dir.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1371991
patch -Np1 -i ../no-crmf.diff
# https://bugzilla.mozilla.org/show_bug.cgi?id=1314968 # https://bugzilla.mozilla.org/show_bug.cgi?id=1314968
patch -Np1 -i ../fix-wifi-scanner.diff patch -Np1 -i ../fix-wifi-scanner.diff
# https://bugs.archlinux.org/task/53890
patch -Np1 -i ../0001-Bug-1338655-Don-t-try-to-build-mp4parse-bindings.-r-.patch
echo -n "$_google_api_key" >google-api-key echo -n "$_google_api_key" >google-api-key
echo -n "$_mozilla_api_key" >mozilla-api-key echo -n "$_mozilla_api_key" >mozilla-api-key
...@@ -64,6 +64,7 @@ ac_add_options --prefix=/usr ...@@ -64,6 +64,7 @@ ac_add_options --prefix=/usr
ac_add_options --enable-release ac_add_options --enable-release
ac_add_options --enable-gold ac_add_options --enable-gold
ac_add_options --enable-pie ac_add_options --enable-pie
ac_add_options --enable-optimize="-O2"
# Branding # Branding
ac_add_options --enable-official-branding ac_add_options --enable-official-branding
...@@ -86,7 +87,6 @@ ac_add_options --with-system-icu ...@@ -86,7 +87,6 @@ ac_add_options --with-system-icu
ac_add_options --with-system-jpeg ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib ac_add_options --with-system-zlib
ac_add_options --with-system-bz2 ac_add_options --with-system-bz2
ac_add_options --with-system-libevent
ac_add_options --with-system-libvpx ac_add_options --with-system-libvpx
ac_add_options --enable-system-hunspell ac_add_options --enable-system-hunspell
ac_add_options --enable-system-sqlite ac_add_options --enable-system-sqlite
...@@ -96,7 +96,6 @@ ac_add_options --enable-system-pixman ...@@ -96,7 +96,6 @@ ac_add_options --enable-system-pixman
# Features # Features
ac_add_options --enable-startup-notification ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter ac_add_options --enable-crashreporter
ac_add_options --enable-alsa
ac_add_options --disable-updater ac_add_options --disable-updater
STRIP_FLAGS="--strip-debug" STRIP_FLAGS="--strip-debug"
...@@ -124,7 +123,7 @@ package() { ...@@ -124,7 +123,7 @@ package() {
cd mozilla-unified cd mozilla-unified
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
_vendorjs="$pkgdir/usr/lib/firefox/browser/defaults/preferences/vendor.js" _vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
install -Dm644 /dev/stdin "$_vendorjs" <<END install -Dm644 /dev/stdin "$_vendorjs" <<END
// Use LANG environment variable to choose locale // Use LANG environment variable to choose locale
pref("intl.locale.matchOS", true); pref("intl.locale.matchOS", true);
...@@ -140,7 +139,7 @@ pref("extensions.shownSelectionUI", true); ...@@ -140,7 +139,7 @@ pref("extensions.shownSelectionUI", true);
pref("browser.tabs.remote.autostart", true); pref("browser.tabs.remote.autostart", true);
END END
_distini="$pkgdir/usr/lib/firefox/distribution/distribution.ini" _distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
install -Dm644 /dev/stdin "$_distini" <<END install -Dm644 /dev/stdin "$_distini" <<END
[Global] [Global]
id=archlinux id=archlinux
...@@ -155,35 +154,35 @@ END ...@@ -155,35 +154,35 @@ END
for i in 16 22 24 32 48 256; do for i in 16 22 24 32 48 256; do
install -Dm644 browser/branding/official/default$i.png \ install -Dm644 browser/branding/official/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png" "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
done done
install -Dm644 browser/branding/official/content/icon64.png \ install -Dm644 browser/branding/official/content/icon64.png \
"$pkgdir/usr/share/icons/hicolor/64x64/apps/firefox.png" "$pkgdir/usr/share/icons/hicolor/64x64/apps/$pkgname.png"
install -Dm644 browser/branding/official/mozicon128.png \ install -Dm644 browser/branding/official/mozicon128.png \
"$pkgdir/usr/share/icons/hicolor/128x128/apps/firefox.png" "$pkgdir/usr/share/icons/hicolor/128x128/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo.png \ install -Dm644 browser/branding/official/content/about-logo.png \
"$pkgdir/usr/share/icons/hicolor/192x192/apps/firefox.png" "$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
install -Dm644 browser/branding/official/content/about-logo@2x.png \ install -Dm644 browser/branding/official/content/about-logo@2x.png \
"$pkgdir/usr/share/icons/hicolor/384x384/apps/firefox.png" "$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
install -Dm644 ../firefox-symbolic.svg \ install -Dm644 ../firefox-symbolic.svg \
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/firefox-symbolic.svg" "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
install -Dm644 ../firefox.desktop \ install -Dm644 ../$pkgname.desktop \
"$pkgdir/usr/share/applications/firefox.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
# Use system-provided dictionaries # Use system-provided dictionaries
rm -r "$pkgdir"/usr/lib/firefox/dictionaries rm -r "$pkgdir"/usr/lib/$pkgname/dictionaries
ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/firefox/dictionaries" ln -Ts /usr/share/hunspell "$pkgdir/usr/lib/$pkgname/dictionaries"
ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/firefox/hyphenation" ln -Ts /usr/share/hyphen "$pkgdir/usr/lib/$pkgname/hyphenation"
# Install a wrapper to avoid confusion about binary path # Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/firefox" <<END install -Dm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<END
#!/bin/sh #!/bin/sh
exec /usr/lib/firefox/firefox "\$@" exec /usr/lib/$pkgname/firefox "\$@"
END END
# Replace duplicate binary with wrapper # Replace duplicate binary with wrapper
# https://bugzilla.mozilla.org/show_bug.cgi?id=658850 # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
ln -srf "$pkgdir/usr/bin/firefox" \ ln -srf "$pkgdir/usr/bin/$pkgname" \
"$pkgdir/usr/lib/firefox/firefox-bin" "$pkgdir/usr/lib/$pkgname/firefox-bin"
} }
diff --git i/old-configure.in w/old-configure.in
index 0a06e470d2085922..d41c8e9d5dd2dbfb 100644
--- i/old-configure.in
+++ w/old-configure.in
@@ -2020,9 +2020,7 @@ if test -n "$_USE_SYSTEM_NSS"; then
AM_PATH_NSS(3.31, [MOZ_SYSTEM_NSS=1], [AC_MSG_ERROR([you don't have NSS installed or your version is too old])])
fi
-if test -n "$MOZ_SYSTEM_NSS"; then
- NSS_LIBS="$NSS_LIBS -lcrmf"
-else
+if test -z "$MOZ_SYSTEM_NSS"; then
NSS_CFLAGS="-I${DIST}/include/nss"
case "${OS_ARCH}" in
# Only few platforms have been tested with GYP
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment