Skip to content
Snippets Groups Projects
Commit db6556fd authored by David Runge's avatar David Runge :chipmunk:
Browse files

Upgrade to 0.5.1.

Remove unnecessary quotes and curly braces.
Update devendoring patch for fluidsynth.
Add debug package.
parent 4cd3ad6d
No related branches found
Tags v20221213.0.110631
No related merge requests found
# Maintainer: David Runge <dvzrv@archlinux.org>
pkgname=gmsynth.lv2
pkgver=0.5.0
pkgrel=2
pkgver=0.5.1
pkgrel=1
pkgdesc="General MIDI LV2 Synth"
arch=('x86_64')
arch=(x86_64)
url="https://x42-plugins.com/x42/x42-gmsynth"
license=('GPL2')
groups=('pro-audio' 'lv2-plugins')
depends=('glibc')
makedepends=('fluidsynth' 'lv2')
checkdepends=('lv2lint')
source=("$pkgname-$pkgver.tar.gz::https://github.com/x42/${pkgname}/archive/v${pkgver}.tar.gz"
"$pkgname-0.4.1-use-system-fluidsynth.patch")
sha512sums=('7059c560c514aa2fc5c342448f5437e29b84c7f391e163e7bb3312f39733270814d01e50dad18a793c3f2e7c5d09314a88dfa72a9c50d951935003741baf6256'
'80dbc28624c2f3636c1ae8599b9b755d9b9733474254f10b2427e00c8d849ff997c5fad7ad80d08af6a67fb6c92946e71cc55d9fe6d45e5c34581d40cd9fde07')
b2sums=('70bcd32a166bcf01afbd1d6cc362bca50759af304603e84c79a9ccd40fd71e49161ce1801a130e7e4b2cfbdc711a21f702eb1e4dfc611d2ee224375f1a483bd0'
'502b5fc39a2b1780cded2fd180d9bab1cd073a9a73654fd5a4f873031ab1575d3a3c1649ff3f636f3da81a2ab00aea87be89a3cc9815de79b2a099584f2b7007')
license=(GPL2)
groups=(pro-audio lv2-plugins)
depends=(glibc)
makedepends=(fluidsynth lv2)
checkdepends=(lv2lint)
options=(debug)
source=(
$pkgname-$pkgver.tar.gz::https://github.com/x42/$pkgname/archive/v$pkgver.tar.gz
$pkgname-0.5.1-use_system_fluidsynth.patch
)
sha512sums=('21b209a44dc9a87130968ad6afaa8c52d25d053463bba9523d4dddbc0bdb26626a8f932360d555002fd31b7ba2c7e245d814ca08eedf0f536955093efd6224aa'
'a0f2a09a6a839c38dc3234a719a633eb221f2afca2a97bbecf17b7d0c8dc71befec3768b882deb20357d55186e81e342cad73eb5e08426a1e2108949d11b3cf2')
b2sums=('b44af70e784d6c0279c4aac7c862a5f32e15336491927bd472da2c0fb298c001c9f34959bbc12ca6695ca7954a11918cb3537c408ce993cfbba220803db1b92f'
'cb327b55536006a862540e769497d138a6815bbee83f9365f97778adf8c542f3ce49e83d07dd532e66c39ce57a4c1eedc79c982b8ac350f22311f9443f682954')
prepare() {
cd "$pkgname-$pkgver"
# use system fluidsynth
patch -Np1 -i "../$pkgname-0.4.1-use-system-fluidsynth.patch"
patch -Np1 -d $pkgname-$pkgver -i ../$pkgname-0.5.1-use_system_fluidsynth.patch
}
build() {
cd "$pkgname-$pkgver"
make
make -C $pkgname-$pkgver
}
check() {
cd "$pkgname-$pkgver"
cd $pkgname-$pkgver
lv2lint -Mpack -I build "http://gareus.org/oss/lv2/gmsynth"
}
package() {
depends+=('libfluidsynth.so')
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir/" PREFIX='/usr' install
install -vDm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
depends+=(
fluidsynth libfluidsynth.so
)
make DESTDIR="$pkgdir/" PREFIX=/usr install -C $pkgname-$pkgver
install -vDm 644 $pkgname-$pkgver/README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
diff -ruN a/Makefile b/Makefile
--- a/Makefile 2019-12-03 00:27:25.000000000 +0100
+++ b/Makefile 2019-12-15 18:26:09.203720789 +0100
@@ -85,7 +85,7 @@
--- a/Makefile 2022-10-31 16:07:16.000000000 +0100
+++ b/Makefile 2022-11-02 22:36:55.426618672 +0100
@@ -101,7 +101,7 @@
else
override CFLAGS += -DPTW32_STATIC_LIB
endif
-override LOADLIBES += `pkg-config $(PKG_UI_FLAGS) --libs glib-2.0`
+override LOADLIBES += `pkg-config $(PKG_UI_FLAGS) --libs fluidsynth`
-override LOADLIBES += `$(PKG_CONFIG) $(PKG_UI_FLAGS) --libs glib-2.0`
+override LOADLIBES += `$(PKG_CONFIG) $(PKG_UI_FLAGS) --libs glib-2.0 fluidsynth`
###############################################################################
@@ -110,38 +110,8 @@
@@ -126,38 +126,8 @@
$(BUILDDIR)%.sf2:
cp -v sf2/$(*F).sf2 $@
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment