-
Lukas Fleischer authoredLukas Fleischer authored
Code owners
Assign users and groups as approvers for specific file changes. Learn more.
PKGBUILD 874 B
# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: alba4k <blaskoazzolaaaron@gmail.com>
pkgname="hyprwayland-scanner"
pkgver=0.3.6
pkgrel=1
pkgdesc="A Hyprland implementation of wayland-scanner, in and for C++"
arch=(x86_64)
url="https://github.com/hyprwm/hyprwayland-scanner"
license=('BSD-3-Clause')
depends=('pugixml')
makedepends=('git' 'cmake' 'gcc')
_archive="${pkgname}-$pkgver"
source=("$_archive.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
provides=(hyprwayland-scaner)
sha256sums=('a274eb00418a36ff04cfc564c9f09c41e8b0b68ab0f44a701807d0383835fc47')
build() {
cd "$_archive"
cmake -DCMAKE_BUILD_TYPE:STRING=Release -DCMAKE_INSTALL_PREFIX=/usr -B build
cmake --build build --config Release
}
package() {
cd "$_archive"
DESTDIR="${pkgdir}" cmake --install build
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}