Skip to content
Snippets Groups Projects
Commit e834bcc3 authored by Christian Hesse's avatar Christian Hesse :stuck_out_tongue_winking_eye:
Browse files

new upstream release

parent ccfd105d
No related branches found
Tags 2.2.3-1
No related merge requests found
diff --git a/keepalived/Makefile.am b/keepalived/Makefile.am
index 86c3ed3a..9a47eb61 100644
--- a/keepalived/Makefile.am
+++ b/keepalived/Makefile.am
@@ -75,26 +75,38 @@ init_DATA = etc/openrc/keepalived
endif
if WITH_IPVS
+# checks for realpath, and also not busybox version which does not support --relative-to
install-exec-hook:
+ $(MKDIR_P) $(DESTDIR)/$(bindir)
@( \
- d=`echo $(bindir) | sed -e "s:^/::"`; \
- s=`echo $(sbindir) | sed -e "s:^/::"`; \
- \
- while [ 1 ]; do \
- d1=`echo $$d | sed -e "s:/.*::"`; \
- s1=`echo $$s | sed -e "s:/.*::"`; \
- if [ $$d1 != $$s1 ]; then \
- break; \
+ realpath --relative-to=/ / >/dev/null 2>&1; \
+ if [ $$? -eq 0 ]; then \
+ $(LN_S) `realpath --relative-to="$(DESTDIR)/$(bindir)" "$(DESTDIR)/$(sbindir)/keepalived"` $(DESTDIR)/$(bindir)/genhash; \
+ else \
+ if [ $(bindir) = $(sbindir) ]; then \
+ d= ; \
+ s= ; \
+ else \
+ d=`echo $(bindir) | sed -e "s:^/::"`; \
+ s=`echo $(sbindir) | sed -e "s:^/::"`; \
+ \
+ while [ 1 ]; do \
+ d1=`echo $$d | sed -e "s:/.*::"`; \
+ s1=`echo $$s | sed -e "s:/.*::"`; \
+ if [ $$d1 != $$s1 ]; then \
+ break; \
+ fi; \
+ d=`echo $$d | sed -e "s:^[^/]*/::"`; \
+ s=`echo $$s | sed -e "s:^[^/]*/::"`; \
+ if [ -z $$d ]; then break; fi; \
+ if [ -z $$s ]; then break; fi; \
+ done; \
+ \
+ d=`echo /$$d/ | sed -e "s:/[^/.]*/:/../:g" -e "s:/[^/.]*/:/../:g" -e "s:^/::"`; \
+ s=$$s/ ; \
fi; \
- d=`echo $$d | sed -e "s:^[^/]*/::"`; \
- s=`echo $$s | sed -e "s:^[^/]*/::"`; \
- if [ -z $$d ]; then break; fi; \
- if [ -z $$s ]; then break; fi; \
- done; \
- \
- d=`echo /$$d/ | sed -e "s:/[^/.]*/:/../:g" -e "s:/[^/.]*/:/../:g" -e "s:^/::"`; \
- \
- $(MKDIR_P) $(DESTDIR)/$(bindir); \
- $(LN_S) $$d$$s/keepalived $(DESTDIR)/$(bindir)/genhash; \
+ \
+ $(LN_S) $$d$${s}keepalived $(DESTDIR)/$(bindir)/genhash; \
+ fi; \
)
endif
......@@ -2,7 +2,7 @@
# Contributor: Andrea Zucchelli <zukka77@gmail.com>
pkgname=keepalived
pkgver=2.2.2
pkgver=2.2.3
pkgrel=1
pkgdesc='Failover and monitoring daemon for LVS clusters'
arch=('x86_64')
......@@ -14,8 +14,18 @@ depends=('glibc' 'libnl' 'openssl' 'file' 'iptables' 'systemd-libs')
optdepends=('ipset: ipset support')
makedepends=('libnfnetlink' 'ipset' 'systemd')
options=('!emptydirs')
source=("https://www.keepalived.org/software/$pkgname-$pkgver.tar.gz")
sha256sums=('103692bd5345a4ed9f4581632ea636214fdf53e45682e200aab122c4fa674ece')
source=("https://www.keepalived.org/software/$pkgname-$pkgver.tar.gz"
'0001-symlink-genhash.patch')
sha256sums=('8391e511c47c256bce4c93169b924da3d37e3f4d88fadc124fae052dc62f302c'
'5ca0af6e4ce60eb611d9d17801057670685c6a98f0ae43c3f60f68f0efdf0606')
prepare() {
cd $pkgname-$pkgver
patch -Np1 < ../0001-symlink-genhash.patch
autoreconf
}
build() {
# trick broken ./configure systemctl test
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment