Skip to content
Snippets Groups Projects
Commit 90654577 authored by George Rawlinson's avatar George Rawlinson :coffee:
Browse files

new upstream release & FS#76610

parent c37676ce
No related branches found
No related tags found
No related merge requests found
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=klystrack-plus
pkgver=0.10.0.alpha1
pkgver=0.10.0.alpha2
pkgrel=1
pkgdesc='A tracker for making C64/NES/Amiga-style chiptunes on a modern platform'
arch=('x86_64')
url='https://github.com/LTVA1/klystrack'
license=('MIT')
depends=(
'glibc'
'alsa-lib'
'sdl2'
'sdl2_image'
'hicolor-icon-theme'
)
makedepends=('git')
_commit='b94ccfac7071e030a25f6c5635c072ae9bf940e9'
_commit='dddea70c9378ab9c3dbd09e5a0283295fcce2ede'
options=('!lto')
source=(
"$pkgname::git+$url#commit=$_commit"
'github.com-LTVA1-klystron::git+https://github.com/LTVA1/klystron'
'update-desktop-file.patch'
'repro-klystrack-plus.patch'
'repro-klystron.patch'
)
b2sums=('SKIP'
'SKIP')
'SKIP'
'5543cae63098a27ee6539cf92f06a87756bbfcbad0e6000eed8c5ad32fb354f18439730d021a278ffd8d4359b8c6847d8c0ae06a882faf1887b8a4c1c912ec50'
'761ef03457b9ea2009b8483608a99befe3444641ef5f351ab3d3d33271bedca1b32a2cec8c9d6fbec0a6d871134915cd5c11111c48b5015019021b61388e0a2c'
'c22be63b5103b9c9c21366df6d0a76b59d3f39054204a56845fe105de54240fc0f269db48330fb52269e9b32bef147bd529c39d1f26a088386c70f5d702168ff')
pkgver() {
cd "$pkgname"
......@@ -34,22 +43,16 @@ prepare() {
# prepare git submodules
git submodule init
git config submodule.klystron.url "$srcdir/github.com-LTVA1-klystron"
git submodule update
# remove png prefix from desktop file
sed -e 's/\.png//' -i linux/klystrack.desktop
# rename klystrack -> klystrack-plus
sed -e 's/klystrack/klystrack-plus/g' -i linux/klystrack.desktop
# use resource path klystrack-plus instead of klystrack
sed -e 's:/lib/klystrack:/lib/klystrack-plus:' -i Makefile
git -c protocol.file.allow=always submodule update
# first pass at ensuring reproducibility by using git commit date
sed -e 's/$(Q)date +"%Y%m%d"/$(Q)git show --no-patch --format=%cd --date=format:%Y%m%d/' -i Makefile
# update desktop file to point to klystrack-plus,
# just in case users have the original klystrack installed
patch --strip 1 --input "$srcdir/update-desktop-file.patch"
cd klystron
sed -e 's/$(Q)date +"%Y%m%d"/$(Q)git show --no-patch --format=%cd --date=format:%Y%m%d/' -i Makefile
# first pass at ensuring reproducibility by using
# git commit date instead of date
patch --strip 1 --input "$srcdir/repro-klystrack-plus.patch"
patch --directory klystron --strip 1 --input "$srcdir/repro-klystron.patch"
}
build() {
......
--- a/Makefile
+++ b/Makefile
@@ -144,7 +144,7 @@ src/version.h: src/version
$(Q)echo '#define VERSION_H' >> ./src/version.h
$(Q)echo '#include "version_number.h"' >> ./src/version.h
$(Q)echo '#define REVISION "' | tr -d '\n' >> ./src/version.h
- $(Q)date +"%Y%m%d" | tr -d '\n' >> ./src/version.h
+ $(Q)git show --no-patch --format=%cd --date=format:%Y%m%d | tr -d '\n' >> ./src/version.h
$(Q)echo '"' >> ./src/version.h
$(Q)echo '#define VERSION_STRING "klystrack-plus " VERSION " " REVISION' >> ./src/version.h
$(Q)echo '#endif' >> ./src/version.h
--- a/Makefile
+++ b/Makefile
@@ -69,7 +69,7 @@ build: Makefile
$(Q)echo '#ifndef KLYSTRON_VERSION_H' > ./src/version.h
$(Q)echo '#define KLYSTRON_VERSION_H' >> ./src/version.h
$(Q)echo '#define KLYSTRON_REVISION "' | tr -d '\n' >> ./src/version.h
- $(Q)date +"%Y%m%d" | tr -d '\n' >> ./src/version.h
+ $(Q)git show --no-patch --format=%cd --date=format:%Y%m%d | tr -d '\n' >> ./src/version.h
$(Q)echo '"' >> ./src/version.h
$(Q)echo '#define KLYSTRON_VERSION_STRING "klystron " KLYSTRON_REVISION' >> ./src/version.h
$(Q)echo '#endif' >> ./src/version.h
--- a/linux/klystrack.desktop
+++ b/linux/klystrack.desktop
@@ -2,9 +2,9 @@
Name=Klystrack-plus
Comment=Chiptune Tracker
Comment[fr]=Tracker 8-bits
-Exec=klystrack %f
+Exec=klystrack-plus %f
Type=Application
-Icon=klystrack.png
+Icon=klystrack-plus
Terminal=false
Categories=AudioVideo;AudioVideoEditing
Keywords=tracker;music;chipsong;
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment