Skip to content
Snippets Groups Projects
Commit da118550 authored by Maxime Gauduin's avatar Maxime Gauduin
Browse files

upgpkg: 2.4.0-1

parent d79eab1a
No related branches found
No related tags found
No related merge requests found
From 0abb7a1c938437000bfca1a9b3706884467c681e Mon Sep 17 00:00:00 2001
From: Haihao Xiang <haihao.xiang@intel.com>
Date: Fri, 7 Dec 2018 13:31:43 +0800
Subject: [PATCH] Check the interface from libva first
This fixes https://github.com/intel/intel-vaapi-driver/issues/419
Signed-off-by: Haihao Xiang <haihao.xiang@intel.com>
---
src/i965_output_wayland.c | 27 ++++++++++++++++-----------
1 file changed, 16 insertions(+), 11 deletions(-)
diff --git a/src/i965_output_wayland.c b/src/i965_output_wayland.c
index 122db953..a637552e 100644
--- a/src/i965_output_wayland.c
+++ b/src/i965_output_wayland.c
@@ -397,6 +397,7 @@ i965_output_wayland_init(VADriverContextP ctx)
struct i965_driver_data * const i965 = i965_driver_data(ctx);
struct dso_handle *dso_handle;
struct wl_vtable *wl_vtable;
+ struct VADriverVTableWayland * const vtable = ctx->vtable_wayland;
static const struct dso_symbol libegl_symbols[] = {
{
@@ -465,25 +466,29 @@ i965_output_wayland_init(VADriverContextP ctx)
if (!i965->wl_output)
goto error;
- i965->wl_output->libegl_handle = dso_open(LIBEGL_NAME);
- if (!i965->wl_output->libegl_handle) {
- i965->wl_output->libegl_handle = dso_open(LIBEGL_NAME_FALLBACK);
- if (!i965->wl_output->libegl_handle)
+ wl_vtable = &i965->wl_output->vtable;
+
+ if (vtable->wl_interface)
+ wl_vtable->drm_interface = vtable->wl_interface;
+ else {
+ i965->wl_output->libegl_handle = dso_open(LIBEGL_NAME);
+ if (!i965->wl_output->libegl_handle) {
+ i965->wl_output->libegl_handle = dso_open(LIBEGL_NAME_FALLBACK);
+ if (!i965->wl_output->libegl_handle)
+ goto error;
+ }
+
+ dso_handle = i965->wl_output->libegl_handle;
+ if (!dso_get_symbols(dso_handle, wl_vtable, sizeof(*wl_vtable),
+ libegl_symbols))
goto error;
}
- dso_handle = i965->wl_output->libegl_handle;
- wl_vtable = &i965->wl_output->vtable;
- if (!dso_get_symbols(dso_handle, wl_vtable, sizeof(*wl_vtable),
- libegl_symbols))
- goto error;
-
i965->wl_output->libwl_client_handle = dso_open(LIBWAYLAND_CLIENT_NAME);
if (!i965->wl_output->libwl_client_handle)
goto error;
dso_handle = i965->wl_output->libwl_client_handle;
- wl_vtable = &i965->wl_output->vtable;
if (!dso_get_symbols(dso_handle, wl_vtable, sizeof(*wl_vtable),
libwl_client_symbols))
goto error;
......@@ -3,32 +3,36 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
pkgname=libva-intel-driver
pkgver=2.3.0
pkgrel=2
pkgver=2.4.0
pkgrel=1
pkgdesc='VA-API implementation for Intel G45 and HD Graphics family'
arch=('x86_64')
url='https://01.org/linuxmedia/vaapi'
license=('MIT')
depends=('libva' 'libdrm')
makedepends=('git' 'meson')
replaces=('libva-driver-intel')
source=("git+https://github.com/intel/intel-vaapi-driver.git#tag=${pkgver}"
427.patch)
sha256sums=('SKIP'
'e51eaf65b1bb09bf62a1b78668da0c268722387cb8eb3c05ec2d7462c651d1c0')
arch=(x86_64)
url=https://01.org/linuxmedia/vaapi
license=(MIT)
depends=(
libva
libdrm
)
makedepends=(
git
meson
)
replaces=(libva-driver-intel)
source=(git+https://github.com/intel/intel-vaapi-driver.git#tag=d595d01d6421eae30824538fa6d150701ed077df)
sha256sums=('SKIP')
pkgver() {
cd intel-vaapi-driver
git describe --tags
}
prepare() {
cd intel-vaapi-driver
# https://github.com/intel/intel-vaapi-driver/issues/419
patch -Np1 -i ../427.patch
# Only relevant if intel-gpu-tools is installed,
# since then the shaders will be recompiled
sed -i '1s/python$/&2/' src/shaders/gpp.py
# Fix undefined variable in src/meson.build
sed -i 's/2.2.0/2.2.0.0/' meson.build
}
build() {
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment