Skip to content
Snippets Groups Projects
Commit 134a301d authored by Aaron Griffin's avatar Aaron Griffin
Browse files

Initial commit of community repo into svn

parents
No related branches found
No related tags found
No related merge requests found
PKGBUILD 0 → 100644
# Maintainer: Geoffroy Carrier <geoffroy@archlinux.org>
# Contributor: Andrea `BaSh` Scarpino <bash.lnx@gmail.com>
# Contributor: William Rea <sillywilly@gmail.com>
# Contributor: Robert Emil Berge <filoktetes@linuxophic.org>
pkgname=lilypond
pkgver=2.12.2
pkgrel=1
pkgdesc="An automated music engraving system"
arch=('i686' 'x86_64')
url="http://lilypond.org"
license=('GPL')
depends=('guile' 'python' 'tetex' 'ghostscript' 'pango' 'fontforge' 'fontconfig')
makedepends=('flex' 'bison' 'gettext' 'mftrace' 'texinfo')
options=('emptydirs')
source=(http://download.linuxaudio.org/lilypond/sources/v2.12/$pkgname-$pkgver.tar.gz)
build() {
cd "$srcdir/$pkgname-$pkgver"
libtoolize --force --copy
aclocal
autoconf
automake
./configure --prefix=/usr --disable-gui
make || return 1
make DESTDIR="$pkgdir" install || return 1
}
md5sums=('681dfbecf8a3710d1400cf9488be716b')
--- src/lilypond-2.10.33/flower/file-name.cc~ 2008-04-04 22:40:39.000000000 +0200
+++ src/lilypond-2.10.33/flower/file-name.cc 2008-04-04 22:40:54.000000000 +0200
@@ -12,6 +12,7 @@
#include <cstdio>
#include <cerrno>
#include <unistd.h>
+#include <limits.h>
using namespace std;
--- src/lilypond-2.10.33/flower/include/rational.hh~ 2008-04-04 22:41:47.000000000 +0200
+++ src/lilypond-2.10.33/flower/include/rational.hh 2008-04-04 22:41:55.000000000 +0200
@@ -10,7 +10,7 @@
#define RATIONAL_HH
#include "std-string.hh"
-
+#include <limits.h>
#include "std-string.hh"
/**
--- src/lilypond-2.10.33/flower/include/std-vector.hh~ 2008-04-04 22:42:32.000000000 +0200
+++ src/lilypond-2.10.33/flower/include/std-vector.hh 2008-04-04 22:42:42.000000000 +0200
@@ -22,6 +22,7 @@
#include <algorithm> /* find, reverse, sort */
#include <functional> /* unary_function */
#include <cassert>
+#include <string>
using namespace std;
--- src/lilypond-2.10.33/lily/include/lily-guile.hh~ 2008-04-04 22:43:15.000000000 +0200
+++ src/lilypond-2.10.33/lily/include/lily-guile.hh 2008-04-04 22:43:23.000000000 +0200
@@ -14,7 +14,7 @@
#endif
#include <libguile.h>
-
+#include <string.h>
/*
Hack for various MacOS incarnations.
--- src/lilypond-2.10.33/lily/include/midi-stream.hh~ 2008-04-04 22:44:09.000000000 +0200
+++ src/lilypond-2.10.33/lily/include/midi-stream.hh 2008-04-04 22:44:18.000000000 +0200
@@ -10,6 +10,7 @@
#include <cstdio>
using namespace std;
+#include <string.h>
#include "std-string.hh"
class Midi_item;
--- src/lilypond-2.10.33/lily/include/engraver.hh~ 2008-04-04 22:44:51.000000000 +0200
+++ src/lilypond-2.10.33/lily/include/engraver.hh 2008-04-04 22:44:59.000000000 +0200
@@ -11,6 +11,7 @@
#include "grob-info.hh"
#include "translator.hh"
+#include <string.h>
/**
a struct which processes events, and creates the #Grob#s.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment