Skip to content
Snippets Groups Projects
Commit d33d7c86 authored by Lukas Fleischer's avatar Lukas Fleischer
Browse files

Upstream update.

parent 0f9a67b8
No related branches found
No related tags found
No related merge requests found
From 33c40d127877179e0cba2f6595816377bb6bcda1 Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Tue, 25 Oct 2016 10:28:14 +0200
Subject: [PATCH 05/10] lib: curl_poll.h: Ensure build on unconfiguredclients.
---
lib/curl_poll.h | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/lib/curl_poll.h b/lib/curl_poll.h
index 6144c42..af25381 100644
--- a/lib/curl_poll.h
+++ b/lib/curl_poll.h
@@ -21,7 +21,9 @@
* KIND, either express or implied.
*
***************************************************************************/
+#ifdef HAVE_CONFIG_H
#include "config.h"
+#endif
#ifdef __cplusplus
extern "C" {
@@ -29,7 +31,7 @@ extern "C" {
#ifdef HAVE_SYS_POLL_H
#include <sys/poll.h>
-#elif defined(HAVE_POLL_H)
+#else
#include <poll.h>
#endif
--
2.5.5
From 916a48ffcb9f1c259a0fc778a2de1be729423092 Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Tue, 25 Oct 2016 21:29:27 +0200
Subject: [PATCH 06/10] lirc.pc: Fix bad library specification (#236).
---
lirc.pc.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/lirc.pc.in b/lirc.pc.in
index 802f00e..5ed7c1c 100644
--- a/lirc.pc.in
+++ b/lirc.pc.in
@@ -10,5 +10,5 @@ includedir=@includedir@
pkgdatadir=@datadir@/lirc
plugindir=${libdir}/lirc/plugins
-Libs: -L${libdir} -llirc
+Libs: -L${libdir} -llirc_client
Cflags: -I${includedir}
--
2.5.5
From 0463f56357d1dd223a4d2882dbc460a0a7a7e9ad Mon Sep 17 00:00:00 2001
From: Alec Leamas <leamas.alec@gmail.com>
Date: Sat, 29 Oct 2016 11:06:50 +0200
Subject: [PATCH 07/10] Build: Use HAVE_UINPUT=1 to force building uinput code
(#238).
---
configure.ac | 7 ++++++-
1 file changed, 6 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index cde9813..08e2c8e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ if test x$XSLTPROC != "xyes"; then
AC_MSG_ERROR([
xsltproc is required to build. It usually comes with libxml])
fi
-AM_CONDITIONAL(HAVE_UINPUT, test -e /dev/uinput)
+AM_CONDITIONAL(HAVE_UINPUT, test -n "$HAVE_UINPUT" -o -e /dev/uinput)
AC_CHECK_PROG([MAN2HTML],[man2html],[yes],[no])
AM_CONDITIONAL(HAVE_MAN2HTML, test x$MAN2HTML = xyes)
AC_CHECK_PROG([DOXYGEN],[doxygen],[yes],[no])
@@ -446,6 +446,11 @@ AM_CONDITIONAL(NEED_PYTHON3, [test "x$enable_python3_fix" = "xyes"])
AC_ARG_VAR(HAVE_WORKING_POLL,[
On cross-compile: Target has a working poll(2) implementation])
+AC_ARG_VAR(HAVE_UINPUT,[
+ If not-empty, assume uinput is available despite missing /dev/uinput
+])
+
+
suffix=$(echo "$VERSION" | sed 's/.*-//')
AM_CONDITIONAL(DEVEL, [test x$suffix = xdevel])
--
2.5.5
......@@ -2,9 +2,9 @@
# Contributor: Paul Mattal <paul@archlinux.org>
pkgname=lirc
_pkgver=0.9.4c
_pkgver=0.9.4d
[[ $_pkgver =~ [a-z]$ ]] && pkgver="${_pkgver:0:-1}.${_pkgver: -1}" || pkgver="$_pkgver"
pkgrel=4
pkgrel=1
epoch=1
pkgdesc="Linux Infrared Remote Control utilities"
arch=('i686' 'x86_64')
......@@ -18,31 +18,12 @@ conflicts=('lirc-utils')
replaces=('lirc-utils')
backup=('etc/lirc/lirc_options.conf' 'etc/lirc/lircd.conf' 'etc/lirc/lircmd.conf')
source=("http://prdownloads.sourceforge.net/${pkgname}/${pkgname}-${_pkgver}.tar.bz2"
0005-lib-curl_poll.h-Ensure-build-on-unconfiguredclients.patch
0006-lirc.pc-Fix-bad-library-specification-236.patch
0007-Build-Use-HAVE_UINPUT-1-to-force-building-uinput-cod.patch
lirc.logrotate
lirc.tmpfiles)
sha1sums=('e6a04fa7447b2c3bc5bac7658fa2cc377ae133ed'
'1f8e8f206c7f2b8275c8a55d15e1520ec35602ac'
'03ddd50f59ce9c44b51a5855a0673cb15ded5fa4'
'0b4d5dfdc940a0233e6f81a07d910a6c84732577'
sha1sums=('5dbfd95a9e290260e6b5febadf685227df9c0529'
'4342b004eb53d51fcbb9af2cf136bb4990874608'
'5cd3f206e6e60632d9bea2ce9d22dbe5283eb129')
prepare() {
cd "${srcdir}/lirc-${_pkgver}"
# Downstream build problems
patch -Np1 -i ../0005-lib-curl_poll.h-Ensure-build-on-unconfiguredclients.patch
patch -Np1 -i ../0006-lirc.pc-Fix-bad-library-specification-236.patch
# devtools chroots have no /dev/uinput
patch -Np1 -i ../0007-Build-Use-HAVE_UINPUT-1-to-force-building-uinput-cod.patch
autoreconf -fi
}
build() {
cd "${srcdir}/lirc-${_pkgver}"
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment