Code owners
Assign users and groups as approvers for specific file changes. Learn more.
PKGBUILD 946 B
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=npm-check-updates
pkgdesc='Find newer versions of dependencies than what your package.json or bower.json allows'
pkgver=17.1.10
pkgrel=1
arch=('any')
url='https://github.com/tjunnone/npm-check-updates'
license=('Apache')
depends=('npm')
makedepends=('git')
source=(https://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
noextract=($pkgname-$pkgver.tgz)
sha512sums=('1a737a29b5330bc069c2c458267b6eba680289a819d3ec71a2bbd424cf66d3a77b025c8af659b7885b00b275c5dd5019673a43e508d9bd60703737bad55cb093')
package() {
npm install -g --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
# Non-deterministic race in npm gives 777 permissions to random directories.
# See https://github.com/npm/npm/issues/9359 for details.
chmod -R u=rwX,go=rX "$pkgdir"
# npm installs package.json owned by build user
# https://bugs.archlinux.org/task/63396
chown -R root:root "$pkgdir"
}