Skip to content
Snippets Groups Projects
Verified Commit 2887a348 authored by Robin Candau's avatar Robin Candau
Browse files

upgpkg: 24.11.0-2: Patch some removed headers back

Those headers are still required by scribus
parent 609b3020
No related branches found
No related tags found
No related merge requests found
pkgbase = poppler
pkgver = 24.11.0
pkgrel = 1
pkgrel = 2
url = https://poppler.freedesktop.org/
arch = x86_64
license = GPL-2.0-only
......@@ -35,10 +35,12 @@ pkgbase = poppler
source = https://poppler.freedesktop.org/poppler-24.11.0.tar.xz
source = https://poppler.freedesktop.org/poppler-24.11.0.tar.xz.sig
source = test::git+https://gitlab.freedesktop.org/poppler/test.git#commit=ff3133cdb6cb496ee1d2c3231bfa35006a5e8410
source = add_removed_headers_back.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
sha256sums = 7723d880565211740c13649d24a300257b86ddd7fa2d208187ff7e5cc8dfbd58
sha256sums = SKIP
sha256sums = SKIP
sha256sums = 3face2bc5303d0c2af0b48685595a988a8a185c4b3726347ffd19563faf9ab50
pkgname = poppler
pkgdesc = PDF rendering library based on xpdf 3.0
......
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# Maintainer: Robin Candau <antiz@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgbase=poppler
pkgname=('poppler' 'poppler-glib' 'poppler-qt5' 'poppler-qt6')
pkgver=24.11.0
pkgrel=1
pkgrel=2
arch=(x86_64)
license=('GPL-2.0-only'
'GPL-3.0-or-later'
......@@ -20,14 +21,23 @@ options=('!emptydirs')
url="https://poppler.freedesktop.org/"
# https://gitlab.freedesktop.org/poppler/poppler
source=(https://poppler.freedesktop.org/${pkgbase}-${pkgver}.tar.xz{,.sig}
# test::git+https://anongit.freedesktop.org/git/poppler/test/#commit=ff3133cdb6cb496ee1d2c3231bfa35006a5e8410
test::git+https://gitlab.freedesktop.org/poppler/test.git#commit=ff3133cdb6cb496ee1d2c3231bfa35006a5e8410
add_removed_headers_back.patch
)
sha256sums=('7723d880565211740c13649d24a300257b86ddd7fa2d208187ff7e5cc8dfbd58'
'SKIP'
'SKIP')
'SKIP'
'3face2bc5303d0c2af0b48685595a988a8a185c4b3726347ffd19563faf9ab50')
validpgpkeys=('CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7') # Albert Astals Cid <aacid@kde.org>
prepare() {
cd "$pkgname-$pkgver"
# Temporary patch to add back removed headers in 24.11.0
# that are still needed by scribus.
# Those headers should be added back in 24.12.0
patch -Np1 < "$srcdir/add_removed_headers_back.patch"
}
build() {
cmake -B build -S "$pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
......
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bb1c73a..7ad1a05 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -675,11 +675,13 @@ if(ENABLE_UNSTABLE_API_ABI_HEADERS)
poppler/Array.h
poppler/CachedFile.h
poppler/Catalog.h
+ poppler/CharCodeToUnicode.h
poppler/DateInfo.h
poppler/Dict.h
poppler/Error.h
poppler/FILECacheLoader.h
poppler/FileSpec.h
+ poppler/FontEncodingTables.h
poppler/FontInfo.h
poppler/Form.h
poppler/Function.h
@@ -720,6 +722,7 @@ if(ENABLE_UNSTABLE_API_ABI_HEADERS)
poppler/UnicodeCClassTables.h
poppler/UnicodeCompTables.h
poppler/UnicodeDecompTables.h
+ poppler/ViewerPreferences.h
poppler/XRef.h
poppler/CharTypes.h
poppler/ErrorCodes.h
@@ -755,6 +758,7 @@ if(ENABLE_UNSTABLE_API_ABI_HEADERS)
splash/SplashBitmap.h
splash/SplashClip.h
splash/SplashErrorCodes.h
+ splash/SplashFont.h
splash/SplashFontEngine.h
splash/SplashFontFile.h
splash/SplashFontFileID.h
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment