Skip to content
Snippets Groups Projects
Commit 839af7fe authored by Chih-Hsuan Yen's avatar Chih-Hsuan Yen
Browse files

python-anyio: add a workaround for https://bugs.python.org/issue45097

parent 4787d767
No related branches found
No related tags found
No related merge requests found
......@@ -16,9 +16,11 @@ optdepends=(
'python-trio: trio backend'
)
source=(https://github.com/agronholm/anyio/archive/$pkgver/anyio-$pkgver.tar.gz
https://github.com/agronholm/anyio/commit/5ed3270c8d12cffc4cd3349d9ff32bc32451ae65.patch)
https://github.com/agronholm/anyio/commit/5ed3270c8d12cffc4cd3349d9ff32bc32451ae65.patch
bpo-45097.diff)
sha256sums=('5872afba5b2a03461e8eb64538d8050d1f64fe54192ad67d8f34f6287ea7c729'
'30e94b5a37c124d3620c77abd835384b224eee3349bea0ddd19f3a268e71c9ca')
'30e94b5a37c124d3620c77abd835384b224eee3349bea0ddd19f3a268e71c9ca'
'ed0ad72f604697d247a2d74f5b4740fcda0fe478040fa6ff75120cd97d5985c8')
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
......@@ -32,6 +34,9 @@ prepare() {
# https://github.com/agronholm/anyio/issues/347
patch -Np1 -i ../5ed3270c8d12cffc4cd3349d9ff32bc32451ae65.patch
# Work around https://bugs.python.org/issue45097
patch -Np1 -i ../bpo-45097.diff
}
build() {
......
diff --git a/pyproject.toml b/pyproject.toml
index d6c4fa1..541290d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,7 +38,8 @@ testpaths = ["tests"]
filterwarnings = [
"error",
"ignore:unclosed <socket.socket.*:ResourceWarning",
- "ignore:unclosed transport <_ProactorSocketTransport.*:ResourceWarning"
+ "ignore:unclosed transport <_ProactorSocketTransport.*:ResourceWarning",
+ "ignore:The loop argument is deprecated.*:DeprecationWarning",
]
markers = [
"network: marks tests as requiring Internet access",
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment