Skip to content
Snippets Groups Projects
Commit fb0765fb authored by Chih-Hsuan Yen's avatar Chih-Hsuan Yen
Browse files
parent c27b8ee2
No related branches found
No related tags found
No related merge requests found
......@@ -2,7 +2,7 @@
pkgname=python-anyio
# https://github.com/agronholm/anyio/blob/master/docs/versionhistory.rst
pkgver=3.3.1
pkgver=3.3.2
pkgrel=1
pkgdesc='High level compatibility layer for multiple asynchronous event loop implementations'
arch=(any)
......@@ -16,19 +16,11 @@ optdepends=(
'python-curio: curio backend'
'python-trio: trio backend'
)
source=(https://github.com/agronholm/anyio/archive/$pkgver/anyio-$pkgver.tar.gz
bpo-45097.diff)
sha256sums=('2f27663b77aa484ca85544f6701f7d6710e9cf4fbb23df0990c8447983aabb32'
'ed0ad72f604697d247a2d74f5b4740fcda0fe478040fa6ff75120cd97d5985c8')
source=(https://github.com/agronholm/anyio/archive/$pkgver/anyio-$pkgver.tar.gz)
sha256sums=('6324b57392a1fef98fb612786cc6cf450b9aced05182e37bde4400f7b340c4cc')
export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
prepare() {
cd anyio-$pkgver
# Work around https://bugs.python.org/issue45097
patch -Np1 -i ../bpo-45097.diff
}
build() {
cd anyio-$pkgver
python setup.py build
......
diff --git a/pyproject.toml b/pyproject.toml
index d6c4fa1..541290d 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -38,7 +38,8 @@ testpaths = ["tests"]
filterwarnings = [
"error",
"ignore:unclosed <socket.socket.*:ResourceWarning",
- "ignore:unclosed transport <_ProactorSocketTransport.*:ResourceWarning"
+ "ignore:unclosed transport <_ProactorSocketTransport.*:ResourceWarning",
+ "ignore:The loop argument is deprecated.*:DeprecationWarning",
]
markers = [
"network: marks tests as requiring Internet access",
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment