Skip to content
Snippets Groups Projects
Commit 3d72403a authored by Felix Yan's avatar Felix Yan
Browse files

upgpkg: 3.2.0-1

parent 97594637
No related branches found
No related tags found
No related merge requests found
......@@ -2,7 +2,7 @@
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
pkgname=python-cliff
pkgver=3.1.0
pkgver=3.2.0
pkgrel=1
pkgdesc="Command Line Interface Formulation Framework"
arch=('any')
......@@ -11,20 +11,13 @@ license=('Apache')
depends=('python-six' 'python-pbr' 'python-cmd2' 'python-prettytable' 'python-pyparsing'
'python-stevedore' 'python-yaml')
makedepends=('git')
checkdepends=('python-testrepository' 'python-mock' 'python-sphinx' 'python-testscenarios')
checkdepends=('python-stestr' 'python-mock' 'python-sphinx' 'python-testscenarios')
options=('!emptydirs')
source=("$pkgname-$pkgver.tar.gz::https://github.com/openstack/cliff/archive/$pkgver.tar.gz"
new-cmd2.patch)
sha512sums=('e65af5ec08df4d7586a1d6821acd283e568227bffee2e5ed8bb40d9f6d4fb17d83fcafc0f1a8ef4293ff7cd2f9e204db35198e58ff7e35d566ffcc03eed5740b'
'9998d90b3b07f624340feca9ab38cd13db789006ff5d658ceeb9b7fe8c74180ddce4e91c57c8696cff997aed390ab17df53a4840e1f02a629c3e824c5ba25c3d')
source=("$pkgname-$pkgver.tar.gz::https://github.com/openstack/cliff/archive/$pkgver.tar.gz")
sha512sums=('94736a94438a868d45558e6eb99e3d98408b5c4d131988600e1191a78a38a571d32b372182379844c5d75fba8742e25605df88a3efa1edc5fb684d4312aef4aa')
export PBR_VERSION=$pkgver
prepare() {
cd cliff-$pkgver
patch -p1 -i ../new-cmd2.patch
}
build() {
cd cliff-$pkgver
python setup.py build
......@@ -32,7 +25,7 @@ build() {
check() {
cd cliff-$pkgver
python setup.py testr
stestr run
}
package() {
......
commit 6c1ddf273f026d9a0daff8305cd98b4516b8f447
Author: Felix Yan <felixonmars@archlinux.org>
Date: Thu Mar 12 08:10:53 2020 +0800
Fix compatibility with new cmd2
Change-Id: I8c926152aa43359be376ec3dea83c42ecc499e80
diff --git a/cliff/interactive.py b/cliff/interactive.py
index 4341d09..473f59a 100644
--- a/cliff/interactive.py
+++ b/cliff/interactive.py
@@ -175,9 +175,16 @@ class InteractiveApp(cmd2.Cmd):
statement.parsed.args = ' '.join(sub_argv)
else:
# cmd2 >= 0.9.1 uses shlex and gives us a Statement.
- statement.command = cmd_name
- statement.argv = [cmd_name] + sub_argv
- statement.args = ' '.join(statement.argv)
+ statement = cmd2.Statement(' '.join(sub_argv),
+ raw=statement.raw,
+ command=cmd_name,
+ arg_list=sub_argv,
+ multiline_command=statement.multiline_command,
+ terminator=statement.terminator,
+ suffix=statement.suffix,
+ pipe_to=statement.pipe_to,
+ output=statement.output,
+ output_to=statement.output_to)
return statement
def cmdloop(self):
diff --git a/requirements.txt b/requirements.txt
index c5f88ce..f89f1da 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -2,7 +2,8 @@
# of appearance. Changing the order has an impact on the overall integration
# process, which may cause wedges in the gate later.
pbr!=2.1.0,>=2.0.0 # Apache-2.0
-cmd2>=0.8.0,!=0.8.3,<0.9.0 # MIT
+cmd2!=0.8.3,<0.9.0;python_version<'3.0' # MIT
+cmd2!=0.8.3;python_version>='3.0' # MIT
PrettyTable<0.8,>=0.7.2 # BSD
pyparsing>=2.1.0 # MIT
six>=1.10.0 # MIT
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment