Skip to content
Snippets Groups Projects
Commit 8796da18 authored by Jelle van der Waa's avatar Jelle van der Waa :construction:
Browse files

python 3.11 rebuild

parent 6a0527be
No related branches found
Tags 0.3.0-1
No related merge requests found
From 5a88b98511047202ce55d4089558a8ef1709d1a5 Mon Sep 17 00:00:00 2001
From: Jelle van der Waa <jelle@archlinux.org>
Date: Fri, 14 Apr 2023 19:05:56 +0200
Subject: [PATCH] test: fix redirect to https
curl does not redirect automatically making the test suite fail to
download the tar.gz.
---
test/svg/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/test/svg/Makefile b/test/svg/Makefile
index 7ac9b685..d80f6e11 100644
--- a/test/svg/Makefile
+++ b/test/svg/Makefile
@@ -10,4 +10,4 @@ clean:
suite:
mkdir suite
- (cd suite; curl -O http://www.w3.org/Graphics/SVG/Test/20110816/archives/W3C_SVG_11_TestSuite.tar.gz; tar xzvf W3C_SVG_11_TestSuite.tar.gz)
+ (cd suite; curl -O https://www.w3.org/Graphics/SVG/Test/20110816/archives/W3C_SVG_11_TestSuite.tar.gz; tar xzvf W3C_SVG_11_TestSuite.tar.gz)
--
2.40.0
......@@ -5,7 +5,7 @@
pkgname=python-pyx
pkgver=0.16
pkgrel=1
pkgrel=2
pkgdesc='Python library for the creation of PostScript and PDF files'
arch=('any')
url="https://pyx-project.org/"
......@@ -13,14 +13,20 @@ license=('GPL')
depends=('python' 'texlive-core')
makedepends=('python-setuptools')
checkdepends=('ghostscript' 'python-pillow' 'python-testfixtures')
source=("https://github.com/pyx-project/pyx/archive/refs/tags/$pkgver/$pkgname-$pkgver.tar.gz")
sha512sums=('2d85ffb4e2bbf88be0a2c77ff0865593794b15fe26424e590e6b2152691c425d27d11a7af5a2e6211774d01a9feaa4c3c00f922862ca5ca42e119f748b0300c2')
source=("https://github.com/pyx-project/pyx/archive/refs/tags/$pkgver/$pkgname-$pkgver.tar.gz"
"0001-test-fix-redirect-to-https.patch")
sha512sums=('2d85ffb4e2bbf88be0a2c77ff0865593794b15fe26424e590e6b2152691c425d27d11a7af5a2e6211774d01a9feaa4c3c00f922862ca5ca42e119f748b0300c2'
'f2d4f052b1b80b3fa87fad7b9b9a06a0a3bcb2c5f1a464acdcf06fb868029d6f9fca415297c4ce607fba771b63a8ce2c95ea7f0454f5d8c52b8f4fd4866b430d')
prepare() {
cd pyx-$pkgver/pyx/data
# https://github.com/pyx-project/pyx/issues/39
sed -i 's|methods = local internal pykpathsea kpsewhich|methods = local internal recursivedir pykpathsea kpsewhich|' pyxrc
echo "recursivedir = /usr/share/texmf-dist/fonts/type1/public/amsfonts/" >> pyxrc
# https://github.com/pyx-project/pyx/pull/43
cd ${srcdir}/pyx-$pkgver/
patch -Np1 -i ${srcdir}/0001-test-fix-redirect-to-https.patch
}
build() {
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment