Skip to content
Snippets Groups Projects
Commit a6cd05af authored by Felix Yan's avatar Felix Yan
Browse files

upgpkg: 5.0.0-1

parent 5f3601a8
No related branches found
Tags 5.0.0-1
No related merge requests found
......@@ -3,24 +3,20 @@
# Contributor: Leif Warner <abimelech@gmail.com>
pkgname=python-rdflib
pkgver=4.2.2
pkgrel=3
pkgver=5.0.0
pkgrel=1
pkgdesc="A Python library for working with RDF, a simple yet powerful language for representing information"
arch=('any')
url="http://rdflib.net/"
license=('BSD')
depends=('python-isodate')
depends=('python-isodate' 'python-pyparsing')
optdepends=('python-html5lib: for html support'
'python-requests: for sparql support')
makedepends=('python-setuptools')
checkdepends=('python-nose' 'python-pyparsing' 'python-six' 'python-html5lib' 'python-sparqlwrapper'
'python-networkx' 'python-decorator')
source=(rdflib-$pkgver.tar.gz::https://github.com/RDFLib/rdflib/tarball/$pkgver
py3.7.diff)
sha1sums=('08fe9d3480af78ca70380eeae082524ce70bb9d3'
'71e6b688c981a3f1387f68944580c1e5d5363915')
prepare() {
patch -d RDFLib-rdflib-* -p1 < py3.7.diff
}
checkdepends=('python-nose' 'python-six' 'python-html5lib' 'python-requests' 'python-networkx'
'python-doctest-ignore-unicode')
source=(rdflib-$pkgver.tar.gz::https://github.com/RDFLib/rdflib/tarball/$pkgver)
sha512sums=('d879c9312a5e6a69ef2edf7931f5e20f6d5c59ce6feb2397e5aeb09843f3568c284f9175b24ac4d513b720dcea82076776d33bfc4492f5d82a17c644586e7b48')
build() {
cd RDFLib-rdflib-*
......@@ -30,10 +26,7 @@ build() {
check() {
cd RDFLib-rdflib-*
#python setup.py test # Will download and install rdflib again
nosetests3 --where=./build/src \
--with-doctest \
--doctest-extension=.doctest \
--doctest-tests
nosetests3
}
package() {
......
diff -u -r RDFLib-rdflib-2fb94c8/rdflib/plugins/sparql/evaluate.py RDFLib-rdflib-2fb94c8-py3.7/rdflib/plugins/sparql/evaluate.py
--- RDFLib-rdflib-2fb94c8/rdflib/plugins/sparql/evaluate.py 2017-01-29 17:51:48.000000000 +0100
+++ RDFLib-rdflib-2fb94c8-py3.7/rdflib/plugins/sparql/evaluate.py 2018-07-29 17:31:55.614217759 +0200
@@ -326,9 +326,12 @@
# import pdb; pdb.set_trace()
res = evalPart(ctx, slice.p)
i = 0
- while i < slice.start:
- res.next()
- i += 1
+ try:
+ while i < slice.start:
+ res.next()
+ i += 1
+ except StopIteration:
+ return
i = 0
for x in res:
i += 1
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment