Skip to content
Snippets Groups Projects
Commit c5efc983 authored by Antonio Rojas's avatar Antonio Rojas
Browse files

Update to 6.1.1

parent 478bd1a2
No related branches found
Tags 0.2.0-5
No related merge requests found
......@@ -3,8 +3,8 @@
# Contributor: Leif Warner <abimelech@gmail.com>
pkgname=python-rdflib
pkgver=5.0.0
pkgrel=5
pkgver=6.1.1
pkgrel=1
pkgdesc="A Python library for working with RDF, a simple yet powerful language for representing information"
arch=('any')
url="http://rdflib.net/"
......@@ -13,17 +13,10 @@ depends=('python-isodate' 'python-pyparsing')
optdepends=('python-html5lib: for html support'
'python-requests: for sparql support')
makedepends=('python-setuptools')
checkdepends=('python-nose' 'python-six' 'python-html5lib' 'python-requests' 'python-networkx'
checkdepends=('python-pytest' 'python-six' 'python-html5lib' 'python-requests' 'python-networkx'
'python-doctest-ignore-unicode')
source=(rdflib-$pkgver.tar.gz::https://github.com/RDFLib/rdflib/tarball/$pkgver
update-sparql-tests.patch)
sha512sums=('d879c9312a5e6a69ef2edf7931f5e20f6d5c59ce6feb2397e5aeb09843f3568c284f9175b24ac4d513b720dcea82076776d33bfc4492f5d82a17c644586e7b48'
'e60e9947b700ce34093a71cb400689f033d58f08a31aecedcca2a0223a6bd04cea645350da196a4b9ddd9727dbc92c840a924313ff2218042d53dd44633c53bc')
prepare() {
cd RDFLib-rdflib-*
patch -Np1 -i ../update-sparql-tests.patch
}
source=(rdflib-$pkgver.tar.gz::https://github.com/RDFLib/rdflib/tarball/$pkgver)
sha512sums=('2381ff71b09ec31a5802fac62ec161d89ec25f695981821541d0b959f803442442e3f6eac14a60722012536e02979cc53d55be42d931024c4d09606e75575163')
build() {
cd RDFLib-rdflib-*
......@@ -32,8 +25,7 @@ build() {
check() {
cd RDFLib-rdflib-*
#python setup.py test # Will download and install rdflib again
nosetests3
pytest
}
package() {
......
From 4cc4801e096e7054a0e14fb2cc3465c06385bb6f Mon Sep 17 00:00:00 2001
From: Natanael Arndt <arndtn@gmail.com>
Date: Thu, 28 Jan 2021 18:56:27 +0100
Subject: [PATCH] Update SPARQL tests since the DBpedia was updated
---
test/test_sparql_service.py | 28 +++++++++++++++-------------
1 file changed, 15 insertions(+), 13 deletions(-)
diff --git a/test/test_sparql_service.py b/test/test_sparql_service.py
index ea1af4134..7bfe8e4c0 100644
--- a/test/test_sparql_service.py
+++ b/test/test_sparql_service.py
@@ -7,14 +7,14 @@
def test_service():
g = Graph()
- q = '''select ?dbpHypernym ?dbpComment
+ q = '''select ?sameAs ?dbpComment
where
{ service <http://DBpedia.org/sparql>
{ select ?dbpHypernym ?dbpComment
where
{
<http://dbpedia.org/resource/John_Lilburne>
- <http://purl.org/linguistics/gold/hypernym> ?dbpHypernym ;
+ <http://www.w3.org/2002/07/owl#sameAs> ?sameAs ;
<http://www.w3.org/2000/01/rdf-schema#comment> ?dbpComment .
} } } limit 2'''
@@ -27,17 +29,17 @@ def test_service():
def test_service_with_bind():
g = Graph()
- q = '''select ?dbpHypernym ?dbpComment ?dbpDeathPlace
+ q = '''select ?sameAs ?dbpComment ?subject
where
- { bind (<http://dbpedia.org/resource/Eltham> as ?dbpDeathPlace)
+ { bind (<http://dbpedia.org/resource/Category:1614_births> as ?subject)
service <http://DBpedia.org/sparql>
- { select ?dbpHypernym ?dbpComment ?dbpDeathPlace
+ { select ?sameAs ?dbpComment ?subject
where
{
<http://dbpedia.org/resource/John_Lilburne>
- <http://purl.org/linguistics/gold/hypernym> ?dbpHypernym ;
+ <http://www.w3.org/2002/07/owl#sameAs> ?sameAs ;
<http://www.w3.org/2000/01/rdf-schema#comment> ?dbpComment ;
- <http://dbpedia.org/ontology/deathPlace> ?dbpDeathPlace .
+ <http://purl.org/dc/terms/subject> ?subject .
} } } limit 2'''
results = helper.query_with_retry(g, q)
@@ -49,17 +51,17 @@ def test_service_with_bind():
def test_service_with_values():
g = Graph()
- q = '''select ?dbpHypernym ?dbpComment ?dbpDeathPlace
+ q = '''select ?sameAs ?dbpComment ?subject
where
- { values (?dbpHypernym ?dbpDeathPlace) {(<http://dbpedia.org/resource/Leveller> <http://dbpedia.org/resource/London>) (<http://dbpedia.org/resource/Leveller> <http://dbpedia.org/resource/Eltham>)}
+ { values (?sameAs ?subject) {(<http://de.dbpedia.org/resource/John_Lilburne> <http://dbpedia.org/resource/Category:1614_births>) (<https://global.dbpedia.org/id/4t6Fk> <http://dbpedia.org/resource/Category:Levellers>)}
service <http://DBpedia.org/sparql>
- { select ?dbpHypernym ?dbpComment ?dbpDeathPlace
+ { select ?sameAs ?dbpComment ?subject
where
{
<http://dbpedia.org/resource/John_Lilburne>
- <http://purl.org/linguistics/gold/hypernym> ?dbpHypernym ;
+ <http://www.w3.org/2002/07/owl#sameAs> ?sameAs ;
<http://www.w3.org/2000/01/rdf-schema#comment> ?dbpComment ;
- <http://dbpedia.org/ontology/deathPlace> ?dbpDeathPlace .
+ <http://purl.org/dc/terms/subject> ?subject .
} } } limit 2'''
results = helper.query_with_retry(g, q)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment