Skip to content
Snippets Groups Projects
Commit f4758050 authored by Evangelos Foutras's avatar Evangelos Foutras :smiley_cat:
Browse files

Fix build of dependent packages with GCC 5.1

parent 604f18df
No related branches found
No related tags found
No related merge requests found
......@@ -2,14 +2,22 @@
pkgname=speexdsp
pkgver=1.2rc3
pkgrel=1
pkgrel=2
pkgdesc="DSP library derived from Speex"
arch=(i686 x86_64)
url="http://www.speex.org/"
license=(BSD)
depends=(glibc)
source=(http://downloads.us.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz)
sha256sums=('4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1')
source=(http://downloads.us.xiph.org/releases/speex/$pkgname-$pkgver.tar.gz
speexdsp-fixbuilds-774c87d.patch)
sha256sums=('4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1'
'76cd6b1187f415d966c8d62003cd87cfb66e4030b250a316aab8f0fbc2de226a')
prepare() {
cd $pkgname-$pkgver
patch -Np1 -i ../speexdsp-fixbuilds-774c87d.patch
autoreconf -vi
}
build() {
cd $pkgname-$pkgver
......
diff --git a/configure.ac b/configure.ac
index 2cd2d1e..1de0c23 100644
--- a/configure.ac
+++ b/configure.ac
@@ -334,6 +334,12 @@ AC_SUBST([USIZE16])
AC_SUBST([SIZE32])
AC_SUBST([USIZE32])
+AS_IF([test "$ac_cv_header_stdint_h" = "yes"], [INCLUDE_STDINT="#include <stdint.h>"],
+ [test "$ac_cv_header_inttypes_h" = "yes"], [INCLUDE_STDINT="#include <inttypes.h>"],
+ [test "$ac_cv_header_sys_types_h" = "yes"], [INCLUDE_STDINT="#include <sys/types.h>"])
+
+AC_SUBST([INCLUDE_STDINT])
+
AC_CONFIG_FILES([
Makefile libspeexdsp/Makefile doc/Makefile SpeexDSP.spec
include/Makefile include/speex/Makefile speexdsp.pc
diff --git a/include/speex/speexdsp_config_types.h.in b/include/speex/speexdsp_config_types.h.in
index 02b82fd..5ea7b55 100644
--- a/include/speex/speexdsp_config_types.h.in
+++ b/include/speex/speexdsp_config_types.h.in
@@ -1,13 +1,7 @@
#ifndef __SPEEX_TYPES_H__
#define __SPEEX_TYPES_H__
-#if defined HAVE_STDINT_H
-# include <stdint.h>
-#elif defined HAVE_INTTYPES_H
-# include <inttypes.h>
-#elif defined HAVE_SYS_TYPES_H
-# include <sys/types.h>
-#endif
+@INCLUDE_STDINT@
typedef @SIZE16@ spx_int16_t;
typedef @USIZE16@ spx_uint16_t;
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment