Skip to content
Snippets Groups Projects
Commit 4aa02929 authored by Jan Alexander Steffens (heftig)'s avatar Jan Alexander Steffens (heftig)
Browse files

1.4.2-1

parent 3a6186f8
No related branches found
Tags 1.4.2-1
No related merge requests found
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com> # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
pkgname=srt pkgname=srt
pkgver=1.4.1 pkgver=1.4.2
pkgrel=2 pkgrel=1
pkgdesc="Secure Reliable Transport library" pkgdesc="Secure Reliable Transport library"
url="https://www.srtalliance.org/" url="https://www.srtalliance.org/"
arch=(x86_64) arch=(x86_64)
license=(MPL2) license=(MPL2)
depends=(openssl) depends=(openssl)
makedepends=(git cmake) makedepends=(git cmake)
_commit=9e52606fae3b32818b5b734d45d3358f4a95cf3f # tags/v1.4.1 _commit=50b7af06f3a0a456c172b4cb3aceafa8a5cc0036 # tags/v1.4.2
source=("git+https://github.com/Haivision/srt#commit=$_commit" source=("git+https://github.com/Haivision/srt#commit=$_commit")
no-rpath.diff) sha256sums=('SKIP')
sha256sums=('SKIP'
'ce9a97d661d796da85a7e4faf9c70c27368d00eb505f85c03a31bba8f22e6847')
pkgver() { pkgver() {
cd $pkgname cd $pkgname
...@@ -22,16 +20,17 @@ pkgver() { ...@@ -22,16 +20,17 @@ pkgver() {
prepare() { prepare() {
cd $pkgname cd $pkgname
patch -Np1 -i ../no-rpath.diff
} }
build() { build() {
cmake -Hsrt -Bbuild \ cmake -S srt -B build \
-DCMAKE_INSTALL_PREFIX=/usr \ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_BINDIR=bin \ -DCMAKE_INSTALL_BINDIR=bin \
-DCMAKE_INSTALL_LIBDIR=lib \ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_INCLUDEDIR=include \ -DCMAKE_INSTALL_INCLUDEDIR=include \
-DENABLE_TESTING=True -DCMAKE_BUILD_TYPE=None \
-DENABLE_STATIC=ON \
-DENABLE_TESTING=ON
cmake --build build cmake --build build
} }
...@@ -42,7 +41,7 @@ check() { ...@@ -42,7 +41,7 @@ check() {
} }
package() { package() {
DESTDIR="$pkgdir" cmake --build build --target install DESTDIR="$pkgdir" cmake --install build
rm "$pkgdir"/usr/bin/{uriparser,utility}-test rm "$pkgdir"/usr/bin/{uriparser,utility}-test
} }
......
diff --git i/CMakeLists.txt w/CMakeLists.txt
index e913122..2cc3c3d 100644
--- i/CMakeLists.txt
+++ w/CMakeLists.txt
@@ -634,7 +634,6 @@ macro(srt_make_application name)
# be placed into the binrary directory anyway.
# XXX not sure about Mac.
# See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
endif()
# We state that Darwin always uses CLANG compiler, which honors this flag the same way.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment