Skip to content
Snippets Groups Projects
Commit 4d934b34 authored by Jan Alexander Steffens (heftig)'s avatar Jan Alexander Steffens (heftig)
Browse files

1.3.0-1

parent c618a4f3
No related branches found
Tags 1.5.2-1
No related merge requests found
# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com> # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
pkgname=srt pkgname=srt
pkgver=1.2.3 pkgver=1.3.0
pkgrel=1 pkgrel=1
pkgdesc="Secure Reliable Transport library" pkgdesc="Secure Reliable Transport library"
url="https://www.srtalliance.org/" url="https://www.srtalliance.org/"
...@@ -9,9 +9,11 @@ arch=(x86_64) ...@@ -9,9 +9,11 @@ arch=(x86_64)
license=(MPL2) license=(MPL2)
depends=(openssl) depends=(openssl)
makedepends=(git cmake ninja) makedepends=(git cmake ninja)
_commit=1367914ea5d7e26be8274e2fffe8b3e7b05ad193 # tags/v1.2.3 _commit=52769952acb191a90a3b6a0523cae99791e91df8 # tags/v1.3.0
source=("git+https://github.com/Haivision/srt#commit=$_commit") source=("git+https://github.com/Haivision/srt#commit=$_commit"
sha256sums=('SKIP') no-rpath.diff)
sha256sums=('SKIP'
'ce9a97d661d796da85a7e4faf9c70c27368d00eb505f85c03a31bba8f22e6847')
pkgver() { pkgver() {
cd $pkgname cd $pkgname
...@@ -20,13 +22,19 @@ pkgver() { ...@@ -20,13 +22,19 @@ pkgver() {
prepare() { prepare() {
mkdir build mkdir build
cd $pkgname
patch -Np1 -i ../no-rpath.diff
} }
build() { build() {
cd build cd build
cmake -G Ninja ../srt \ cmake -G Ninja ../srt \
-DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_PREFIX=/usr \
ninja -DCMAKE_INSTALL_BINDIR=bin \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_INCLUDEDIR=include \
-DENABLE_TESTING=True
cmake --build .
} }
check() { check() {
...@@ -35,7 +43,13 @@ check() { ...@@ -35,7 +43,13 @@ check() {
} }
package() { package() {
DESTDIR="$pkgdir" ninja -C build install DESTDIR="$pkgdir" cmake --build build --target install
rm "$pkgdir"/usr/bin/*-test
# Build tries this but fails when DESTDIR is set
ln -s srt-live-transmit "$pkgdir/usr/bin/stransmit"
ln -s srt-ffplay "$pkgdir/usr/bin/sfplay"
} }
# vim:set ts=2 sw=2: # vim:set ts=2 sw=2:
......
diff --git i/CMakeLists.txt w/CMakeLists.txt
index e913122..2cc3c3d 100644
--- i/CMakeLists.txt
+++ w/CMakeLists.txt
@@ -634,7 +634,6 @@ macro(srt_make_application name)
# be placed into the binrary directory anyway.
# XXX not sure about Mac.
# See this name used already in install(${TARGET_srt} LIBRARY DESTINATION...).
- set(FORCE_RPATH LINK_FLAGS -Wl,-rpath,.,-rpath,../${CMAKE_INSTALL_LIBDIR} BUILD_WITH_INSTALL_RPATH TRUE INSTALL_RPATH_USE_LINK_PATH TRUE)
endif()
# We state that Darwin always uses CLANG compiler, which honors this flag the same way.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment