Skip to content
Snippets Groups Projects
Commit e521d01b authored by Giancarlo Razzolini's avatar Giancarlo Razzolini
Browse files

Upstream changed the tarball filename to all lowercase, without creating

a new version. They also included source code from this bug:

https://bugs.launchpad.net/terminator/+bug/1668481

Changed the name back and also removed the unnecessary patch.
parent c2d9507f
No related branches found
No related tags found
No related merge requests found
=== modified file 'terminatorlib/terminator.py'
--- terminatorlib/terminator.py 2017-02-26 16:15:11 +0000
+++ terminatorlib/terminator.py 2017-02-28 16:04:37 +0000
@@ -401,7 +401,7 @@
window.grab_focus()
try:
t = GdkX11.x11_get_server_time(window.get_window())
- except AttributeError:
+ except (TypeError, AttributeError):
t = 0
window.get_window().focus(t)
@@ -417,7 +417,7 @@
window.grab_focus()
try:
t = GdkX11.x11_get_server_time(window.get_window())
- except AttributeError:
+ except (TypeError, AttributeError):
t = 0
window.get_window().focus(t)
=== modified file 'terminatorlib/window.py'
--- terminatorlib/window.py 2017-02-13 16:30:37 +0000
+++ terminatorlib/window.py 2017-02-28 16:07:28 +0000
@@ -311,7 +311,7 @@
self.grab_focus()
try:
t = GdkX11.x11_get_server_time(self.get_window())
- except AttributeError:
+ except (TypeError, AttributeError):
t = 0
self.get_window().focus(t)
else:
......@@ -6,26 +6,23 @@
pkgname=terminator
pkgver=1.91
pkgrel=4
pkgrel=5
pkgdesc='Terminal emulator that supports tabs and grids'
arch=('any')
url='https://gnometerminator.blogspot.com/p/introduction.html'
license=('GPL2')
depends=('gsettings-desktop-schemas' 'libkeybinder3' 'libnotify' 'python2-cairo' 'python2-dbus' 'python2-psutil' 'python2-gobject' 'vte3' 'xdg-utils')
makedepends=('intltool')
source=("https://launchpad.net/terminator/gtk3/${pkgver}/+download/${pkgname^}-${pkgver}.tar.gz"
"https://launchpad.net/terminator/gtk3/${pkgver}/+download/${pkgname^}-${pkgver}.tar.gz.asc"
"0001-wayland-fix.patch::https://launchpadlibrarian.net/309178299/wayland_fix.diff")
md5sums=('44e6be581abc9b52fe2e665cbb572201'
'SKIP'
'32281658b0cacef023c8020106952b31')
sha512sums=('7037077680475164011e19bb5ff16b55a5b4f0b71941d6bfb2ba00af8289eff6f9bf62dded3a6f4f21f199e9e070d0731b19a4ac60fdd429815d708e7fdc3edd'
'SKIP'
'66db2930bd2c1eafcd0e6e33be9478137d08643205ffb3ff12ad07318e2f465a889d894b6d580d3d4480ea263caca69d7174b6627c52296ab94a42fb6cda1a27')
source=("https://launchpad.net/terminator/gtk3/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz"
"https://launchpad.net/terminator/gtk3/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz.asc")
md5sums=('2eed999d7a41f2e18eaa511bbbf80f58'
'SKIP')
sha512sums=('6feee96cda08f913601d3b01e51632bed87712ddb5ce577df1daa8a5fe4e8dc39075d5e21f87b865d1f007c7e1070ee2c0c814540c9c7786f0f24fbee762a03d'
'SKIP')
validpgpkeys=('FE67C001C72200A71DE9EFA5DB69E1780B95EF32')
prepare() {
cd "${srcdir}/${pkgname^}-${pkgver}"
cd "${srcdir}/${pkgname}-${pkgver}"
# python2 fix
for file in terminatorlib/{,plugins/}*.py; do
......@@ -35,19 +32,16 @@ prepare() {
# fix run without gconf
sed -i 's/except ImportError:/except ValueError:/' terminatorlib/config.py
# Fix for https://bugs.archlinux.org/task/53106
patch -Np0 -i "$srcdir/0001-wayland-fix.patch"
}
build() {
cd "${srcdir}/${pkgname^}-${pkgver}"
cd "${srcdir}/${pkgname}-${pkgver}"
python2 setup.py build
}
package() {
cd "${srcdir}/${pkgname^}-${pkgver}"
cd "${srcdir}/${pkgname}-${pkgver}"
python2 setup.py install --skip-build --root="${pkgdir}" --optimize=1
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment